Author Topic: DNS of your domain doesn't point to this server or you have htaccess  (Read 2293 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hi,

i am pretty new to CWP and are trying to get SSL to work. However, something is not working. I get the error message DNS of your domain doesn't point to this server or you have htaccess restrictions

- i dont have any htaccess file installed on public_html
- Here is the DNS configuration:
https://imgur.com/a/f1HXqrQ
- This is the DNS configuration on the CWP side
https://imgur.com/a/IxHpkiQ
- The a-record is pointing to the server
https://www.whatsmydns.net/#A/ruimtereizen.net
- But still i cant get auto ssl to work
https://imgur.com/a/Xr5UzXq

update 1:
after deleting the whole account i created a new account. Enabling AutoSSL gives the following

AutoSSL Issue Failed![Sat Sep  8 01:17:19 UTC 2018] Single domain='ruimtereizen.net'
[Sat Sep  8 01:17:19 UTC 2018] Getting domain auth token for each domain
[Sat Sep  8 01:17:19 UTC 2018] Getting webroot for domain='ruimtereizen.net'
[Sat Sep  8 01:17:19 UTC 2018] Getting new-authz for domain='ruimtereizen.net'
[Sat Sep  8 01:17:20 UTC 2018] The new-authz request is ok.
[Sat Sep  8 01:17:20 UTC 2018] Verifying:ruimtereizen.net
[Sat Sep  8 01:17:23 UTC 2018] ruimtereizen.net:Verify error:Invalid response from http://ruimtereizen.net/.well-known/acme-challenge/1TD1F0gjN_6_AtetI_OTiA61jKio9GFh0meIdU5Q93c:
[Sat Sep  8 01:17:23 UTC 2018] Please check log file for more details: /root/.acme.sh/acme.sh.log

Update 3 Added log file ( last 20 lines )

[Sat Sep  8 01:17:23 UTC 2018] url='https://acme-v01.api.letsencrypt.org/acme/challenge/qTI9zjrTJ-rDcX5Ij5hJKfXvrzfhP97ucabLhia4a5A/7153854755'
[Sat Sep  8 01:17:23 UTC 2018] timeout=
[Sat Sep  8 01:17:23 UTC 2018] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Sat Sep  8 01:17:23 UTC 2018] ret='0'
[Sat Sep  8 01:17:23 UTC 2018] ruimtereizen.net:Verify error:Invalid response from http://ruimtereizen.net/.well-known/acme-challenge/1TD1F0gjN_6_AtetI_OTiA61jKio9GFh0meIdU5Q93c:
[Sat Sep  8 01:17:23 UTC 2018] pid
[Sat Sep  8 01:17:23 UTC 2018] No need to restore nginx, skip.
[Sat Sep  8 01:17:23 UTC 2018] _clearupdns
[Sat Sep  8 01:17:23 UTC 2018] skip dns.
[Sat Sep  8 01:17:23 UTC 2018] _on_issue_err
[Sat Sep  8 01:17:23 UTC 2018] Please check log file for more details: /root/.acme.sh/acme.sh.log
[Sat Sep  8 01:17:23 UTC 2018] url='https://acme-v01.api.letsencrypt.org/acme/challenge/qTI9zjrTJ-rDcX5Ij5hJKfXvrzfhP97ucabLhia4a5A/7153854755'
[Sat Sep  8 01:17:23 UTC 2018] payload='{"resource": "challenge", "keyAuthorization": "1TD1F0gjN_6_AtetI_OTiA61jKio9GFh0meIdU5Q93c.X3u0s504PaG8KagYPEDKk-vjOgth4theAXWD5muR5qo"}'
[Sat Sep  8 01:17:23 UTC 2018] POST
[Sat Sep  8 01:17:23 UTC 2018] _post_url='https://acme-v01.api.letsencrypt.org/acme/challenge/qTI9zjrTJ-rDcX5Ij5hJKfXvrzfhP97ucabLhia4a5A/7153854755'
[Sat Sep  8 01:17:23 UTC 2018] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Sat Sep  8 01:17:24 UTC 2018] _ret='0'
[Sat Sep  8 01:17:24 UTC 2018] code='400'

What other things can i do to make it work?

regards jerome
« Last Edit: September 08, 2018, 01:32:20 AM by nme »

Offline
*****
Re: DNS of your domain doesn't point to this server or you have htaccess
« Reply #1 on: September 08, 2018, 07:52:17 PM »
try nginx webserver and issue the certs.

Offline
****
Re: DNS of your domain doesn't point to this server or you have htaccess
« Reply #2 on: September 22, 2018, 01:50:09 PM »
I had a similar problem.  I looked at my vhost config file and saw that I had a 301 redirect for my domain.  I deleted that redirect and was able to get a new cert.

Offline
*
Re: DNS of your domain doesn't point to this server or you have htaccess
« Reply #3 on: August 11, 2019, 11:34:09 PM »
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty  then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add new user account with the Affected Domain name.


04. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

05. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

ns1         14400   IN      A       (Public IP)
ns2         14400   IN      A       (Public IP)
www         14400   IN      A      (Public IP)

06. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.
« Last Edit: August 12, 2019, 12:03:01 AM by amqshaker »

Offline
*
Re: DNS of your domain doesn't point to this server or you have htaccess
« Reply #4 on: August 12, 2019, 05:34:04 AM »
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. Adjust the file from /etc/hosts:

    nano /etc/hosts

    **Make the values like this[Change here]:     
     
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
[your server local ip]   example1.example.com     example1
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
     

04. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add a new user account with the Affected Domain name.

05. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

06. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

   ns1         14400   IN      A       (Public IP)
   ns2         14400   IN      A       (Public IP)
   www         14400   IN      A       (Public IP)

07. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

Offline
****
Re: DNS of your domain doesn't point to this server or you have htaccess
« Reply #5 on: August 12, 2019, 12:29:09 PM »
Disable csf firewall and try it again.  thats what worked for me.