Author Topic: Replace self signed CWP SSL cert on server hostname with letīs encrypt ssl cert  (Read 9436 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Followed http://wiki.centos-webpanel.com/hostname-ssl-with-letsencrypt
which generated a cert for my server hostname,
but the cert got installed in one of my user accounts which has a website with the server domain, i.e. the server hostname is 'server.domain.com' and the main domain of a user account is 'domain.com'. Is that a bad thing to do? (Only I use the server and user accounts). In any case, how can I put the cert for the server in the right place so I can login to CWP, server.domain.com:2031, without a warning and using the autoSSL cert?
Thanks

Offline
*
Hello.
Here's how I manually solved this issue from CWP control panel:
Security > SSL Generator > SSL Certificate Manager
in Install SSL Certificate using Manual option select the certificate you want to install on your host, and in Domain field specify your hostname e.g. srv1.domain.tld and click Install.
This will install your chosen SSL on the your host.
Regards.

Offline
*
The new module for SSL via Letīs Encrypt actually works just fine, except for the 'custom install - also for server hostname) install.

Using all other options in the module works like a dream, but there is no option on how to get the server hostname, eg. srv1.dmoain.ldt to work as smoothly as the other options in the module...?

Checking around the web, it shows that most people with this problem, canīt find the correct path to put into the box and donīt know if they have to set 2031 in the port setting and actually how to get the Custom Install to setup and replace the CWP generated and self signed SSL cert...

I havenīt found anybody who made this work just by filling out the boxes in the 'custom install' option in the module, but have found an ocean of more or less strange options on how to circumvent the present setup to make it work...

Maybe it would be a good idea to make a step-by-step information for all to follow to avoid many asking the same question here and many other places...?


Must Follow :
http://forum.centos-webpanel.com/ssl/install-letsencrypt-ssl-certificate-for-your-server-hostnamefqdn-100-working/

Offline
*
Changing the hostname doesn't work in all cases.

i.e.

On first attempt it tried to generate a certificate but error message said that the the validation failed.
Now, it just keeps generating self signed certificate.  ???

I have this problem too.  It generates only a self signed certificate. 

I have tested auto SSL on another domain and it works OK, but I can't get one generated for my panel hostname.

Offline
*
It worked for me by saving the host name but you have to use the 2031 port and not 2087!