Author Topic: Apache only using localhost certificate after updates + wrong webroot  (Read 1370 times)

0 Members and 1 Guest are viewing this topic.


Want to say first, thank you for any help provided. I am at a loss here after a day and a half of searching and banging my head. Here is the situation.

I was running CWP in nginx+varnish+apache for a while with no problems. Until yesterday. Centos7 had a ton of updates for me, and I went through and did them, and one of them was httpd.

After I restarted the server, I started getting 503 errors thrown at me from Varnish. Figuring some config went weird somewhere, I went back to just Apache in CWP, and that is where I seem to be getting the main issues.

No matter what I seem to do, all my domains pull the certificate for the localhost and not the AutoSSL certificates generated by CWP.

Not only that, but if I push past my browsers certificate error message... the webpage still doesn't load. I just get "Index of..." with zero files listed. This happens for all my domains currently.

I tried digging around .conf files, and the different vhosts conf files all seem to be present still and how they should be. I tried to fix by adjusting different things in ssl.conf in /etc/httpd/conf.d and with httd.conf in /etc/httpd/conf, but either it wouldn't fix it or I couldn't get Apache to restart after the changes.

I am at a loss here. Because the one other time something like this happened I was able to fix it by rebuilding the apache server by compiling it and then rebuilding the vhosts file.

This time when I go into the new areas for domain configs and what not, or try to select different webserver setups (apache, apache+nginx, etc) and let it rebuild vhosts... it still doesn't fix.

I am so at a loss here, because literally the only thing that changed from it working to it not working is the Centos7 updates, and I don't remember it messing me up this much before. The last time this happened, I didn't get the SSL issue. Just the issue with the default apache index page loading up, and that was easy to fix that time.

Thank you again for any help, and if you need any config files or logs from me then let me know :)

My main domain is

EDIT: To add that I have tried some various things from other posts. I have fixed permissions already, since that's a nice catch all fix at times lol

I can also force one of my domains to SSL right by editing /etc/httpd/conf.d/ssl.conf and changing the cert to work with my main domain,

But the webroot is still listing empty for some reason. It's like it's not even wanting to use the conf files in /usr/local/apache *shrug* No idea why so far lol
« Last Edit: December 05, 2018, 03:39:03 AM by docbray »

Re: Apache only using localhost certificate after updates + wrong webroot
« Reply #1 on: December 05, 2018, 08:16:58 AM »
sounds like you have installed default apache from centos which is not part of cwp and that could be causing all these issues.

VPS & Dedicated server provider with included FREE Managed support for CWP.

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Re: Apache only using localhost certificate after updates + wrong webroot
« Reply #2 on: December 05, 2018, 03:28:01 PM »
Thanks for the reply!

I got it all fixed up now! That was exactly it. Centos installed its own apache with default configs as part of a wider yum update.

Removed that, recompiled apache from CWP, cleared out errors from my troubleshooting and everything is up again!

The only thing that kept CWP's apache from starting was that I had re-did a couple subdomains, but hadn't done SSL for them yet. So apache was complaining about certs not existing in the vhosts conf files. But AutoSSL fixed that up super quick.

Thanks again for the pointing in the right direction!

Re: Apache only using localhost certificate after updates + wrong webroot
« Reply #3 on: December 10, 2018, 06:29:39 AM »

i hope you are good. i have install a certificate of my one account which is ssl  from autossl. but when i  go to on open a roundcube its show ssl error and redirect son my hostname ssl certificate instead of my account certificate (  .can any body help me on this .  i need to install my certificate on this. looking forward your quick response.