Author Topic: SSL for Hostname  (Read 590 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
SSL for Hostname
« on: June 12, 2019, 01:53:34 AM »
I need to put ssl on my hostname.

I saw a video of the CWP channel itself, but it seems that my version is not the same as the video, not the wik link.
Links: https://www.youtube.com/watch?v=Au0aE5ZqqvU / http://wiki.centos-webpanel.com/hostname-ssl-with-letsencrypt

Could you please tell me a step by step how to install SSL on hostname?

My domain is registered, and I just created the dns zone:
Image: https://prnt.sc/o0pc8i


How should I proceed?

Thank you.

Offline
*****
Re: SSL for Hostname
« Reply #1 on: June 12, 2019, 09:40:38 PM »
make sure you have a hostname which resolves to your Public IP.

then go to CWP.Admin -> Server settings -> click Change hostname( this will set hostname and install SSL to the hostname)

After restart cwpsrv from the terminal by running the command below

sh /scripts/restart_cwpsrv



Offline
*
Re: SSL for Hostname
« Reply #2 on: June 13, 2019, 02:39:17 PM »
make sure you have a hostname which resolves to your Public IP.

then go to CWP.Admin -> Server settings -> click Change hostname( this will set hostname and install SSL to the hostname)

After restart cwpsrv from the terminal by running the command below

sh /scripts/restart_cwpsrv

I did the procedure. Now just wait?

Offline
*****
Re: SSL for Hostname
« Reply #3 on: June 13, 2019, 07:03:31 PM »
i dont understand your question

Offline
*
Re: SSL for Hostname
« Reply #4 on: July 01, 2019, 05:44:20 AM »
Hi - thanks so much. That worked perfectly.

But I think another issue exists after following the below directions. It now has stated that the certificate is valid for port 2031(after I restart as directed).

Unfortunately for port 2087 it now shows that although the certificate is valid that there is still insecurity. I am happy to use 2031 but should i be concerned about 2087 not being secure?

make sure you have a hostname which resolves to your Public IP.

then go to CWP.Admin -> Server settings -> click Change hostname( this will set hostname and install SSL to the hostname)

After restart cwpsrv from the terminal by running the command below

sh /scripts/restart_cwpsrv
« Last Edit: July 01, 2019, 06:37:08 AM by luddite33 »

Offline
*
Re: SSL for Hostname
« Reply #5 on: July 18, 2019, 04:15:10 PM »
I used the free Let's Encrypt certificate. There is a detailed manual on GitHab how to get it. Do not forget to set a reminder host-tracker.com/Blog/Domain_ssl to extend the certificate. If you follow the instructions, then there should be no difficulties.
« Last Edit: July 18, 2019, 04:33:39 PM by Arkana »

Offline
*
Re: SSL for Hostname
« Reply #6 on: July 18, 2019, 04:33:01 PM »
Hi, I tried by changing hostname but still I am getting ssl cert invalid and all browser requiring to access cwp by going advanced setting and manually accepting SSL.

I tried manual installation ssl by generating certificate from SSLFREE site. But that too did not worked. Any suggestion how may the issue fix?

Offline
*****
Re: SSL for Hostname
« Reply #7 on: July 20, 2019, 08:34:52 PM »
Hi, I tried by changing hostname but still I am getting ssl cert invalid and all browser requiring to access cwp by going advanced setting and manually accepting SSL.

I tried manual installation ssl by generating certificate from SSLFREE site. But that too did not worked. Any suggestion how may the issue fix?

restart cwp after issuing certificate.
click restart cwp services on the dashboard