Author Topic: Every menu item showing : High Performace WebServers Configuration  (Read 1006 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
I logged to both my servers using CWP and I am getting this below on every item I click on to configure CWP.. I really don't want to upgrade or make changes.. How do I fix this or skip this?




-----------------------------------
High Performace WebServers Configuration
Welcome to new and advanced webservers configuration, we are now giving you the flexibility and performance unlike anything else.
- PHP-FPM Selector with the ability to run different version per domain or subdomain
- PHP-FPM with additional cache options for best performances
- Advanced WebServers, that allows you to run custom webservers with different setup per domain

WebServers Setup per domain
If you have enabled Nginx/Varnish/Apache as main webservers with PHP-FPM this allows you to have the highest flexibility.
You can define for each domain or subdomain what webservers to use, example:
- domain-1.com can run Nginx + PHP-FPM
- domain-2.com can run Nginx + Apache + PHP-FPM
- domain-3.com can run Nginx + Varnish + Apache + PHP-FPM
- domain-4.com can run Nginx + Varnish + Apache + PHP-CGI(suphp, current setup like before in cwp)
- domain-5.com can run Nginx + Varnish + Tomcat
- domain-6.com can run Nginx + Varnish + Ruby

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #1 on: December 02, 2018, 11:55:00 PM »
Code: [Select]
http://forum.centos-webpanel.com/high-performance/wordpress-high-performance-instructions/msg20121/?topicseen#msg20121

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #2 on: December 02, 2018, 11:59:53 PM »
Same here.

I misunderstood the message and thought that I could install it as an option so I screwed up and installed it. Now I can't do anything because it says I need to rebuild my servers. This is BULLS!T the way they did this.

They did not elaborate on the advantages and disadvantages of PHP-FMP. After some research, it is my understanding that PHP-FMP does not let you have a different PHP version on a per directory basis, you can no longer have a seperate php.ini file per directory and you cannot specify which PHP version you want to use per directory, via htaccess files. Am I wrong? If I'm correct, then why in the world did the CWP developers say that PHP-FMP has, "flexibility and performance unlike anything else"? I'm guessing there's no way to undo this now  >:( >:( >:( >:( >:(
« Last Edit: December 03, 2018, 12:16:02 AM by jeffshead »

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #3 on: December 03, 2018, 12:15:35 AM »
I do not want to do this update..     I cant risk this on a production server.

How do I avoid this update and get back to my menus so I can manage my server...

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #4 on: December 03, 2018, 12:22:39 AM »
The more I think about the authoritarian manner in which they pushed this update the more I'm leaning to going back to my previous control panel. This is BS! They need to do a better job of explaining the loss of "flexibility" if you take this "upgrade".

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #5 on: December 03, 2018, 12:23:44 AM »
The reconstruction is very easy, just make sure to check the option that I put in the image.
Now you can have different webserver conbinations by domains and up to subdomain

Code: [Select]
https://prnt.sc/lpvcow

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #6 on: December 03, 2018, 12:42:44 AM »
Thanks but I need different PHP versions per directory. Being limited to domain or subdomain will not be granular enough.

Can you specify PHP 7.2 for a domain and PHP 5.6 for a specific directory in the same domain with PHP-FMP?

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #7 on: December 03, 2018, 01:03:12 AM »
Have you tried going to Manage WebServers Configuration and place the domain settings in CGI mode?

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #8 on: December 03, 2018, 01:23:20 AM »
Do you want to install php-fpm?
Install

PHP-FPM Selector
Start Complier (build & Install)
Select the PHP version you are using.



Apache only
Set version to 7
Select Force Apache to use PHP-FPM





Select Webservers Main Conf
Rebuild all vhosts on save
« Last Edit: December 03, 2018, 01:38:11 AM by bobyrosagame »

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #9 on: December 03, 2018, 01:39:55 AM »
The vhost template menu is gone after this "upgrade". I lost all of the customization that I did. All vhosts were rebuilt and a really weird thing I found is that one account is supposed to use a different IP address. It shows that the correct IP is set to that account but when I check the vhost file for that account's domain, it's set to the shared IP. This sucks!

Offline
**
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #10 on: December 03, 2018, 05:38:10 PM »
@josemnunez is right, the per-directory configuration, in theory, must be handled in CGI mode.

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #11 on: December 05, 2018, 06:33:27 AM »
I too wish to remove or skip this. I'm not interested in it, and don't want to possibly break something if I install it unnecessarily.

How do I do this please?

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #12 on: December 10, 2018, 06:35:22 AM »
Another victim here!

You cannot get around this screen.  Every menu now has the forced install PHP-FPM screen.  When you select install and the version it does the build in the background but thats it!

How do we get around this?  Can someone post a tutorial of what needs to be done or how to go back.

ALSO this update has affected my client logins.  They've gained a new theme but can do anything with an error message saying contact your administrator.

 >:( >:(

EDIT: more context...

I am using PHP 7.027 and I can choose only this option in CWP7.admin

When I go to select default web servers its set to Apache only but I cannot tick force FPM and rebuild because it says its not installed.  I have clicked on install and build / then the options and php 7.027 which runs in the background.

The results: https://prnt.sc/lsxkpd

I have restarted the server and some screens have come back.
« Last Edit: December 10, 2018, 07:14:38 AM by The_Anomaly »

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #13 on: December 10, 2018, 02:18:37 PM »
Another one. Why are you forcing to install php-fpm? Why not just a warning?

Same error as last reply on build process:


'ioncube_loader_lin_5.5_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.5_ts.so'
'ioncube_loader_lin_5.6.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6.so'
'ioncube_loader_lin_5.6_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6_ts.so'
'ioncube_loader_lin_7.0.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0.so'
'ioncube_loader_lin_7.0_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0_ts.so'
'ioncube_loader_lin_7.1.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1.so'
'ioncube_loader_lin_7.1_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1_ts.so'
'ioncube_loader_lin_7.2.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2.so'
'ioncube_loader_lin_7.2_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/opcache.sh: line 3: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /opcache.so
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
--2018-12-10 13:59:13--  https://pecl.php.net/get/apcu-5.1.12.tgz
Resolving pecl.php.net (pecl.php.net)... 104.236.228.160
Connecting to pecl.php.net (pecl.php.net)|104.236.228.160|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 105890 (103K) [application/octet-stream]
Saving to: 'apcu-5.1.12.tgz'

     0K .......... .......... .......... .......... .......... 48%  376K 0s
    50K .......... .......... .......... .......... .......... 96%  752K 0s
   100K ...                                                   100% 6501G=0.2s

2018-12-10 13:59:13 (519 KB/s) - 'apcu-5.1.12.tgz' saved [105890/105890]

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 8: /opt/alt/php-fpm72/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 9: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 13: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /apcu.so
exe:/opt/alt/php-fpm72/usr/sbin/php-fpm
Redirecting to /bin/systemctl restart httpd.service

Build Completed
###################

Offline
*
Re: Every menu item showing : High Performace WebServers Configuration
« Reply #14 on: December 10, 2018, 02:50:29 PM »
Another one. Why are you forcing to install php-fpm? Why not just a warning?

Same error as last reply on build process:


'ioncube_loader_lin_5.5_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.5_ts.so'
'ioncube_loader_lin_5.6.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6.so'
'ioncube_loader_lin_5.6_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6_ts.so'
'ioncube_loader_lin_7.0.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0.so'
'ioncube_loader_lin_7.0_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0_ts.so'
'ioncube_loader_lin_7.1.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1.so'
'ioncube_loader_lin_7.1_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1_ts.so'
'ioncube_loader_lin_7.2.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2.so'
'ioncube_loader_lin_7.2_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/opcache.sh: line 3: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /opcache.so
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
--2018-12-10 13:59:13--  https://pecl.php.net/get/apcu-5.1.12.tgz
Resolving pecl.php.net (pecl.php.net)... 104.236.228.160
Connecting to pecl.php.net (pecl.php.net)|104.236.228.160|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 105890 (103K) [application/octet-stream]
Saving to: 'apcu-5.1.12.tgz'

     0K .......... .......... .......... .......... .......... 48%  376K 0s
    50K .......... .......... .......... .......... .......... 96%  752K 0s
   100K ...                                                   100% 6501G=0.2s

2018-12-10 13:59:13 (519 KB/s) - 'apcu-5.1.12.tgz' saved [105890/105890]

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 8: /opt/alt/php-fpm72/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 9: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 13: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /apcu.so
exe:/opt/alt/php-fpm72/usr/sbin/php-fpm
Redirecting to /bin/systemctl restart httpd.service

Build Completed
###################

Did you look at the entire log?  I had virtual memory issues. I increased the swap file size on my VPS and now have no problems compiling.