Author Topic: Updating to PHP 7.* breaks DNS Master/Slave  (Read 677 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Updating to PHP 7.* breaks DNS Master/Slave
« on: October 16, 2019, 08:39:44 PM »
So since PHP 5 will soon be EOL and I have a new setup, I thought it was a good idea to upgrade with the php switcher to a new version of php, i did go for 7.9. After updating I could not log in anymore in to my DNS Master/Slave UI, cause the switcher does not install all needed modules for that feature.

I tried to repair the DNS Manager GUI with the ioncube solution mentioned on the wiki or forum here somewhere, but no effect.
I would imagine that if you use the extra switcher feature, it would take in account that people run other addons from CWP on their setups.

Maybe it is possible to build such a function in, in a next release that the modules who are needed for DNS Master/Slave also are getting installed and configured. Since their are already a bunch of php modules checked in the list, so a few more checkboxes ticked won't hurt and will bring many people joy, instead of re-installing the nameserver again.

greetings
Martend