Author Topic: Very Strange Update beahviour (every 4 hours), what is going on? (Worried)  (Read 5164 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
I am especially worried about the last log email I got, since suddenly something with @gmail.com was popping up as get URL. Maybe someone is trying to hijack the update mechanism? (Hopefully not)

This was the last update that was "fine" this morning:

04:04: Cron <root@XXXX> [ ! -f /etc/cron.hourly/0anacron ] && run-parts /etc/cron.daily

Quote
/etc/cron.daily/cwp:



====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
Your CWP version: 0.9.8.17

No update needed, your CWP is up to date.
XXXX
Date which backup script is using: 2016-07-07 02:02:05

PHP Notice:  Undefined variable: ssh_check_r_connection in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

Notice: Undefined variable: ssh_check_r_connection in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7
PHP Notice:  Undefined variable: ssh_check_r_connection in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

Notice: Undefined variable: ssh_check_r_connection in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

[...]


Then 12 minutes later things started getting strange every 4 hours:

4:12: Cron <root@XXX> /usr/local/cwp/php54/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php

Quote



====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
Your CWP version: 0.9.8.17
PHP Warning:  file_get_contents(http://centos-webpanel.com/webpanel/main.php?app=rc4key&version=0.9.8.17): failed to open stream: HTTP request failed!  in /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php(1) : eval()'d code(1) : eval()'d code on line 8
PHP Warning:  Division by zero in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
PHP Notice:  String offset cast occurred in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
PHP Notice:  Uninitialized string offset: 0 in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
PHP Warning:  Division by zero in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
PHP Notice:  String offset cast occurred in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
PHP Notice:  Uninitialized string offset: 0 in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php(1) : eval()'d code(1) : eval()'d code on line 1
[lots of these 3 above ...]
XXX

12:12: Cron <root@XXX> /usr/local/cwp/php54/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php

Quote



====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
Your CWP version: 0.9.8.17

No update needed, your CWP is up to date.
XXX


16:12: Cron <root@XXX> /usr/local/cwp/php54/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php

Quote



====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
Your CWP version: 0.9.8.17

No update needed, your CWP is up to date.
XXX


20:12: Cron <root@XXX> /usr/local/cwp/php54/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php

Quote

====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
PHP Warning:  file_get_contents(http://...@gmail.com&version=0.9.8.17): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error
 in /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php(1) : eval()'d code(1) : eval()'d code on line 7
Your CWP version: 0.9.8.17

No update needed, your CWP is up to date.
XXX
« Last Edit: July 07, 2016, 07:36:59 PM by ripieces »

Offline
*
(Edited the post above and removed duplicate lines in second log and thus fit everything in a single post.)
« Last Edit: July 07, 2016, 07:34:55 PM by ripieces »

Offline
*
 :-[
I have the same problem. Now is worsen. I cannot access CWP through URL http://my-ip:2030. I see this message: "No Loader is installed. Please contact support."

I sent question to support team. Now i waiting for their reply.

Offline
*
I am having the same issue of "No Loader is installed. Please contact support." The installation was successful and i have copied the console output and it shows everything was fine. Please help me to sort this out. I am in need of urgent hosting of 3 informational websites.

Regards,

Gavin

Offline
*
ya same evey i have it :(

Offline
*
I am guessing that this has to do something with ioncube loader. I have tried searching so many things on google but none come to this issue. I have even tried reinstalling ioncube loader but its saying "its already installed"


@cwp support, please reply. so many users are facing the same issue.

Regards,


Offline
*
this is all ok..there was some issue with cwp site overloaded and because of that some of you had this error in the cron email.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Dear Administrator,

I am not having the issue with cron job or email. I have installed cwp on a fresh server. I am not able to open cwp panel by using http://my-ip:2030 or https://my-ip:2031. I am getting this error:

"No Loader is installed. Please contact support."

Screenshot.



 I have not been able to open cwp admin once. Though services are running, default apache page is loading. phpinfo is working in a php file. pls tell me what should I do to make it work.

Thanks in advance,

Regards.

Gavin

Offline
*****
this will be resolved

Offline
*
this is all ok..there was some issue with cwp site overloaded and because of that some of you had this error in the cron email.

 :o Okay, if you say so :)

It seems to work mostly without errors now.
The last interesting thing I got in such a mail was:
Quote
sh: service: command not found

Thank you for your reply, I was afraid that something more dangerous was going on than just the site being overloaded :)

Offline
*
Dear Support,

When will be the issue, of the below quoted error, fixed. Please tell me if i should try reinstalling the complete server, or should i wait for something from your end to be fixed. I wonder how some issue in you infra. can cause my admin panel to not load with this error. Please suggest.

Regards,

G

Dear Administrator,

I am not having the issue with cron job or email. I have installed cwp on a fresh server. I am not able to open cwp panel by using http://my-ip:2030 or https://my-ip:2031. I am getting this error:

"No Loader is installed. Please contact support."

Screenshot.



 I have not been able to open cwp admin once. Though services are running, default apache page is loading. phpinfo is working in a php file. pls tell me what should I do to make it work.

Thanks in advance,

Regards.

Gavin

Offline
*
for this error "No Loader is installed. Please contact support.", try to restart cwp
Code: [Select]
service cwpsrv restart
and if this issue continues even after restart then run the command bellow and again restart
Code: [Select]
echo "zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.4.so" >> /usr/local/cwp/php54/php.ini
Code: [Select]
service cwpsrv restart
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Hi

Thanks alot, the echo ***** method made it working. Now i am able to login.

Please tell me if i need to do the echo for loader everytime when changing the php version.

Regards,


Offline
*
I would have to disagree that this issue is "not a problem". I've been getting the weird obfuscated emails every 4 hours. It is apparent that something got seriously mangled on centos-wp's side of things.

I am therefore left with no other option than to wipe our testing server clean and utilize a different panel..

Things to consider:

This issue with the obfuscated code has been ongoing since 07/03/16. Any other company would have had this major concern corrected that same day.

Support requests alerting of the issue shouldn't be ignored, and then discounted wholesale with "don't worry it's ok" type remarks.

The gui has been at a standstill as far as development for the last year. It is slow and buggy. When people bring this to cwp's attention - they are told that their server is too slow. Please. I guess everyone that runs cwp has a slow server.

Centos-wp has absolutely no connection with the Centos Linux operating system. The whole reason I installed it, is because I thought it was a project endorsed by the actual Centos company.
Centos released a statement saying that they are not connected, and they are very unhappy that cwp insists on using their name without their permission.

All of the above, but mostly the shoddy support has lead me to this decision. 

I strongly suggest others consider doing the same. Without going too deep into it - if you value the security of your server - you should not let another day go by with cwp installed. This is serious, folks.

If on the other hand, you don't mind that all of your data can be easily compromised - please stay with cwp - and keep your head in the sand.

-A concerned former cwp user

(P.S. I have 30 years coding experience, and have been contracted out by various fortune 500 companies for security audits. So, I do know what I am talking about)

Offline
*
[...]
I strongly suggest others consider doing the same. Without going too deep into it - if you value the security of your server - you should not let another day go by with cwp installed. This is serious, folks.

If on the other hand, you don't mind that all of your data can be easily compromised - please stay with cwp - and keep your head in the sand.
[...]

I mainly chose CWP because it has a lot of features I wanted and is "free".

At the time I chose (February) it I wasn't aware that huge parts of the CWP related code are obfuscated, I actually thought it would be open source or something. However it is my fault for not checking better.

I am actually also worried about the security issues that CWP has or had, for example:

- File owning issues (might have been fixed by now)
http://forum.centos-webpanel.com/centos-webpanel-bugs/quotas-stack-up-(new-users-inherits-quotas-of-existing-users)/

- File permission issues (which I fixed my self, I don't really know if it's a CWP bug that others have too or only me):
http://forum.centos-webpanel.com/backup/backup-access-rights-(all-users-can-access)/

- The default GUI does not allow to install a PHP 5.x version that doesn't have security issues, meaning many users will end up with vulnerable installations:
http://forum.centos-webpanel.com/php/php-version-selector-vulnerabilities/


I am thankful for the time and work CWP developers put into CWP, however, at this point in time I cannot recommend CWP to other people due to i.e. the above reasons. Actually as of now I will be recommending the guy I manage the server with to buy a CPANEL license for the next server (if possible in the budget we have).

Maybe CWP developers should get rid of the "free" idea and switch to s.th. else, but then again that might cause a hit to the popularity of the panel. But currently it seems to me as if they don't have the time and resources to keep CWP reasonably safe to use for dumb users like me.

Edit: I am not saying that CWP is bad, but security is a number one concern for me - I mean I rather spend a bit of money on s.th. that is supposed to be secure, than having a free ride that ends up with me being screwed.
« Last Edit: July 08, 2016, 02:28:08 PM by ripieces »