Control Web Panel

WebPanel => DNS => Topic started by: Mike101 on June 19, 2021, 06:26:50 PM

Title: What am I doing wrong?
Post by: Mike101 on June 19, 2021, 06:26:50 PM
Ip addresses and domains have been changed for obvious reasons.

Private/server ip assigned by ethernet -
Public ip found on Google myip 31.875.9.999
Nameserver ns1 and ns2 (pointed to my public ip on both 123 reg and cwp nameserver setup)

I have just got myself a refurbished r620 to play around on at home. My home broadband & router are with EE, all standard setup.

I am wanting to run a website from home, this is for learning but do want it publicly accessible so i can access when not at home.

Setup at the moment is,
R620 server
Idrac setup and works
Ethernet connection
Vmware esxi 7 installed and working as far as I can see, not sure on network setup, does this matter?
Vm made and centos 7 minimal installed
Updated server
Opened ports 53, 80 and 443 on my router for the private ip
Installed cwp (free but will be upgrading when I fix this)
Setup cwp on nat network
Setup custom nameservers on cwp as ns1 and ns2 pointing to my public ip
Setup custom nameservers on 123 reg pointing to the same public ip
Setup an account on cwp with the same domain which the ip is also my public ip

Leafdns says zone are 92%. The fail is learns can't resolve my nameservers.

I can access my public ip from anywhere but none the main domain doesn't work and neither does the hostname.

All of the records cwp made automatically point to my public domain not my private server ip.

I have tried to point my custom nameservers to the private ip on my server but 123 reg don't allow private ips for custom nameservers, is this my problem?

I had a thought I should be pointing my custom nameservers to the primary and secondary dns ip of my router instead of my public ip?

Or do the dns ips in tcp/ip information on my router mean nothing?

I have tried for a few days, reinstalled etc to see if I missed somthing, followed several tutorials but can't find the right answer.

Thank you for any help, much appreciated.
Title: Re: What am I doing wrong?
Post by: Mike101 on June 20, 2021, 03:33:31 PM

I deleted all my zone that where made apart from the named zones.

I deleted my user account.

Redone everything as before apart from I changed some numbers on my soa like 7200 to 3600 and 86400 (if I remember correctly) to 10800. Restarted everything including server. Then ran ccleaner on my device. Loaded mobile data and it is know working correctly somehow!

Leafdns says at 97% just my ptr needs setup which is fine.
Title: Re: What am I doing wrong?
Post by: Mike101 on June 20, 2021, 03:40:55 PM
Take that back worked for 5 minutes now doesn't.
Title: Re: What am I doing wrong?
Post by: studio4host on June 20, 2021, 05:19:34 PM
dns is based on the account IP, also you should always use public IP on the dns and then on your network router setup NAT networking to local IP.