Control Web Panel

WebPanel => Installation => Topic started by: kobby on April 29, 2015, 11:36:00 PM

Title: Access to Centos Web Panel not working with SSL / https
Post by: kobby on April 29, 2015, 11:36:00 PM
Hi,

I did fresh install Centos 6 on Amazon EC2, then installed CWP and I can access the webpanel with http.
But not with https. I am using Firefox 37.0.2 on Mac. I get the error message, that the secure connection failed, the connection was interrupted. I also tried with IE and Safari. Same problems.

AWS security is switched off (all traffic allowed) and if try with telnet I get a connection to the port 2031.
I also tried to switch of iptables.

The certificate is in /etc/pki/tls and the config file seems to be okay?
In the panel, I cannot see other problems or errors.

Any ideas?

Thank you
Kobby
Title: Re: Access to Centos Web Panel not working with SSL / https
Post by: kobby on May 01, 2015, 06:30:28 PM
Hello,

I found out, that the problem was the internal IP of Amazon Web Services AWS and EC2 and the elastic IP.
This has to be done:

vi /usr/local/cwpsrv/conf.d/cwp-ssl.conf

Listen 2031
<VirtualHost 123.456.789.012:2031>
        ServerName 123.456.789.012
        SSLEngine on
        SSLCertificateKeyFile /etc/pki/tls/cwp-123.456.789.012.key
        SSLCertificateFile /etc/pki/tls/cwp-123.456.789.012.cert
        SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>

change to:

Listen 2031
<VirtualHost *:2031>
        ServerName *
        SSLEngine on
        SSLCertificateKeyFile /etc/pki/tls/cwp-123.456.789.012.key
        SSLCertificateFile /etc/pki/tls/cwp-123.456.789.012.cert
        SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>

service cwpsrv restart

Now it works fine with https.

regards
Kobby
Title: Re: Access to Centos Web Panel not working with SSL / https
Post by: erm3nda on May 01, 2015, 07:27:10 PM
This solution only applies to cwp webpanel SSL at port 2031.

What happend with https of the cwp domains?
I guess the vHost files would be affected on the same way because the Elastic IP.

Can u check for that?