Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Leo

Pages: [1]
1
Updates / Re: After update today, nginx/1.20.0 error
« on: December 29, 2021, 05:54:49 AM »
Somehow the last update messed up everything. It changed the default package and all domains in my account got suspended. Their vhost file is not reverting back to original so I had to fix it one by one manually. File and folder permissions also got messed up. I am only using the stable version update which is supposed to be 2 weeks tested and all of a sudden an update breaks my entire file system. I think I will stop with auto updates. It's simply an invitation for disaster in a production environment.

2
Updates / Write error: Broken pipe
« on: January 17, 2021, 02:02:19 AM »
This is (part of) what I received in the cron.daily update email

 
Code: [Select]
13800K .......... .......... .......... .......... .......... 99% 40.9M 0s
 13850K .......... .......... .......... .......... .......... 99% 35.0M 0s
 13900K .......... .......... .......... .......... .......... 99% 1.22M 0s
 13950K .......... .......... .......... .                    100%  809K=13s

2021-01-17 03:08:27 (1.06 MB/s) - ‘phpMyAdmin-5.0.4-all-languages.zip’ saved [14316903/14316903]

tr: write error: Broken pipe
tr: write error
Redirecting to /bin/systemctl reload httpd.service
Redirecting to /bin/systemctl reload httpd.service

Date which backup script is using: 2021-01-17 03:08:31

/etc/cron.daily/cwp_acme.sh:

[Sun Jan 17 03:08:31 +03 2021] Already uptodate!
[Sun Jan 17 03:08:31 +03 2021] Upgrade success!
/etc/cron.daily/cwp_bandwidth:

So this part: tr: write error: Broken pipe

Is this a problem, something I need to fix? If yes, how do I go about it, please?

Thanks in advance for help.

3
phpmyadmin autologin no longer works after this update. Is there a fix for that?

And they have messed up the UI with this update. It feels like this is the 2012 version. I guess there's nothing we can do about this.

4
Updates / PHP Imagemagick error after last update
« on: May 19, 2020, 11:58:17 PM »
Hello,

After the recent update, my error log is filled with these:

[Wed May 20 02:52:57.192784 2020] [:error] [pid 1412:tid 140090567730944] [client 77.88.5.198:38030] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/imagick.so' - libMagickWand.so.5: cannot open shared object file: No such file or directory in Unknown on line 0

This happens with every PHP process. Imagemagick isn't being used in these processes.

I haven't changed anything myself. This is either about the recent CWP version update or the yum update.

Anyone knows how to fix this?

5
CentOS 7 Problems / How to rotate access logs
« on: April 07, 2020, 10:46:02 AM »
I have just noticed that my hard drive has been running out of space. Checking what's bloating the drive, I've found out that one of the access logs has become 7 GB's, accumulating data for months.

Is there a way to clear these logs on a, say, monthly basis? That's what the rotate system does, right? How do I go about it? I have noticed that there is a Logrotate manager section in the CWP control panel but I don't know how to configure it. It'd be better if that page was designed more user friendly. It should be like configuring a backup, select which log to rotate, select interval (week/month etc) and hit Submit.

6
E-Mail / Re: Email from my domain
« on: January 29, 2020, 01:03:41 PM »
It's probably spoofed. Gmail should dismiss it. Don't worry about it.

7
Updates / File Manager problem after update to 0.9.8.932
« on: January 28, 2020, 07:15:09 PM »
Hello,

I have noticed a minor issue after the last update. "Save File" button doesn't work anymore. I have tried to diagnose the problem through Chrome console and this is the error I receive upon hitting the button:

"Uncaught ReferenceError: go_save is not defined at HTMLInputElement.onclick"

Please provide a quick fix for this. File Manager is a handy tool I use frequently.

8
CentOS-WebPanel Bugs / Fix Permissions feature problem
« on: December 03, 2019, 12:59:05 AM »
Since the last update, Fix Permissions feature is not working correctly. It used to do it's job in a matter of seconds without any hassle, now it takes forever meanwhile causing a spike on the server load. The spike doesn't cool off until I reboot the server. I use this feature often so this is an important matter for me. Please look into this.

9
Updates / Server load spiked after latest update
« on: November 20, 2019, 05:33:52 AM »
I have updated to the latest version about an hour ago.
Currently it's: CWPpro version: 0.9.8.919

First, it broke apache. I have run update_cwp manually it's fixed.

Ever since the update; the server's load has spiked 10-20 fold. Right now it's not a busy hour so the load should be less than 1.00, even below 0.50. But it's currently at (Load: 9.35  8.76  6.50). This is like this since the update. Something is wrong.

Please look into this. I think another update is needed.

10
Installation / CWPPRO upgrade
« on: March 17, 2019, 07:55:13 PM »
Hello,

This is my first topic. First of all, thanks for creating this great panel.

I have been using CWP for a few months. Although I don't really need the pro version, I purchased a license to appreciate the good work.

Now in order to upgrade to pro, I ran the command
Code: [Select]
sh /scripts/update_cwp
The result is:
Code: [Select]
====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
sed: can't read /opt/alt/php-fpm*/usr/php/php.ini: No such file or directory

Any ideas why this happens?

Thank you

Pages: [1]