Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - gailclark80

Pages: [1]
1
Apache / Wordpress pingbacks not working
« on: July 22, 2021, 02:03:55 AM »
My website is based on WordPress 5.8. and my VPS is running on CWP7 Pro. The pingbacks of the website have not worked for a long time. I have searched many articles. The reason why it does not work may be related to the host or control panel. How can I debug it?

2
Apache / Apache log file too large
« on: April 25, 2021, 01:12:03 AM »
I found that the apache log file is too large, how to clear the log? how to make the apache log save a file every day by date?

/usr/local/apache/domlogs/mydomain.log-5.1GB
/usr/local/apache/logs/access_log-4.5GB
/usr/local/apache/logs/suphp_log-3.6GB

I changed suphp_log to suphp_log-, and then changed it to suphp_log. Now the modification time of suphp_log has not changed for a long time, indicating that the system no longer uses suphp_log. How do I fix it?

3
CentOS 7 Problems / wordpress can not upload images
« on: February 05, 2021, 06:38:28 AM »
my WordPress running on CWP7, PHP 7.027

Today, my wordpress can’t upload images suddenly, the error is as follows:

“Post-processing of the image failed likely because the server is busy or does not have enough resources. Uploading a smaller image may help. Suggested maximum size is 2500 pixels.”


I open the apache error_log, the following error is prompted
AH00052: child pid 4822 exit signal Segmentation fault (11)

I have searched many methods and tried all of them, but none of them can solve the problem. I tried the following methods

1. Change these data in php.ini
post_max_size = 128M
upload_max_filesize = 128M
max_execution_time = 360
memory_limit = 1024M


2. Add this to functions.php of my theme
add_filter(‘wp_image_editors’, function() {return array(‘WP_Image_Editor_GD’ );} );

3. Add this to wp-includes/functions.php
function use_gd_editor($array) {
return array(‘WP_Image_Editor_GD’, );
}
add_filter(‘wp_image_editors’,’use_gd_editor’ );

4. install imagick module for PHP

How to solve this problem?

The strange thing is that in addition to this wordpress, I can't upload pictures on another wordpress on another VPS, and the same error occurs. This VPS is also running on CWP7

Thank you very much!

4
Apache / .htaccess problem
« on: September 24, 2020, 11:44:23 AM »
I install Magento on my VPS.

There are two lines of code in .htaccess
    Options +FollowSymLinks
    RewriteEngine on

Internal server error will appear when visiting the website.

If I delete "Options +FollowSymLinks", the website is working fine.

Will deleting this line of code cause security problems? Is there any other code that can replace it and ensure the website works normally?

thank you!




5
Apache / mod_cloudflare not work
« on: March 14, 2019, 08:12:59 AM »
Hi
After installing mod_cloudflare, the apache log can record the real visitor IP address, but when I want to block some spam IP in .htaccess, it doesn't seem to work. How can I solve this problem?

I use Cpanel for another website. After installing mod_cloudflare, I can block spam IP in .htaccess, so I think the problem I experienced may be related to CWP. Has anyone experienced such a problem?

6
Apache / mod_cloudflare not work
« on: July 24, 2018, 01:44:08 AM »
I install the mod_cloudflare by following command. but I found the mod_cloudflare do not work, the $_SERVER['REMOTE_ADDR'] return IP of CloudFlare.

I have checked the /usr/local/apache/conf/httpd.conf,  there is no # on the LoadModule cloudflare_module  modules/mod_cloudflare.so. so the mod_cloudflare should be loaded.

Any suggestion?


yum install libtool git -y

git clone https://github.com/cloudflare/mod_cloudflare.git && cd mod_cloudflare

/usr/local/apache/bin/apxs -a -i -c mod_cloudflare.c

systemctl restart httpd && /usr/local/apache/bin/httpd -M|grep cloudflare

7
MySQL / can not export magento database via PhpMyAdmin
« on: May 30, 2018, 02:55:57 AM »
My CWP7 work fine, but when I export Magento database via PhpMyAdmin, it has an error "a form on this page has more than 1000 fields. on submission, some of the fields might be ignored, due to PHP's max_input_var configuration".

So I change the max_input_vars to 10000 in /usr/local/php/php.ini and restart apache, Varnish and mysql server. But still can't export Magento database.

I install XAMPP on my local computer, the max_input_vars is disable, I can export Magento successful.

8
CentOS-WebPanel Bugs / Installing shared extensions error
« on: May 28, 2018, 08:07:28 AM »
I switch to PHP 7.026
I got below error, and the installing is stop

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20151012/

I run sestatus

SELinux status:                 disabled


Anyone know how to fix it

9
Apache / Leverage browser caching
« on: May 13, 2018, 03:44:58 AM »
Hi
Before my VPS ran Apache Only, and I add blow codes in .htaccess, Google PageSpeed Insights said the "Leverage browser caching" working fine.
<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|webp|js|css|swf|x-html|css|xml|js|woff|woff2|ttf|svg|eot)(\.gz)?$">
<IfModule mod_expires.c>
AddType application/font-woff2 .woff2
ExpiresActive On
ExpiresDefault A0
ExpiresByType image/webp A2592000
ExpiresByType image/gif A2592000
ExpiresByType image/png A2592000
ExpiresByType image/jpg A2592000
ExpiresByType image/jpeg A2592000
ExpiresByType image/ico A2592000
ExpiresByType image/svg+xml A2592000
ExpiresByType text/css A2592000
ExpiresByType text/javascript A2592000
ExpiresByType application/javascript A2592000
ExpiresByType application/x-javascript A2592000
ExpiresByType application/font-woff2 A2592000
</IfModule>
<IfModule mod_headers.c>
Header set Expires "max-age=2592000, public"
Header unset ETag
Header set Connection keep-alive
FileETag None
</IfModule>
</FilesMatch>
# END LBCWpFastestCache


Now I switch the server to Apache & Varnish Cache & Nginx Reverse Proxy, the previous codes has stopped work, so I search on google and add below codes, but PageSpeed Insights still said my website do not support "Leverage browser caching," how to do let my website support Leverage browser caching?

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType text/css "access plus 1 month"
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType text/x-javascript "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresDefault "access plus 1 month"
</IfModule>

## EXPIRES CACHING ##

10
FTP / can not login FTP
« on: January 24, 2018, 03:24:07 AM »
My FTP often have such a problem.

Response:   331 User ****** OK. Password required
Command:   PASS *********
Response:   230 OK. Current restricted directory is /
Status:   Server does not support non-ASCII characters.
Status:   Connected
Status:   Retrieving directory listing...
Command:   PWD
Response:   257 "/" is your current location
Command:   TYPE I
Response:   200 TYPE is now 8-bit binary
Command:   PASV
Response:   227 Entering Passive Mode (*******)
Command:   MLSD
Error:   Connection timed out
Error:   Failed to retrieve directory listing

Please tell me how to fix this problem?

11
Varnish / Install Varnish SSL error
« on: January 18, 2018, 08:49:10 AM »
Intall the vanish buy selected Apache & Varnish Cache & Nginx Reverse Proxy and click "Save & Rebuild Configuration", but the CWP show some error as below

Nginx ERROR Detected ! nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/pki/tls/private/www.***.com.key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch) nginx: configuration file /etc/nginx/nginx.conf test failed

i have use SSL checker verify my website, the SSL work fine.

any suggestion?

12
Apache / enable Gzip
« on: January 11, 2018, 03:06:33 AM »
Hi
I enable Gzip by this guide http://idroot.net/tutorials/how-to-enable-gzip-compression-on-apache/


#LoadModule deflate_module modules/mod_deflate.so change to LoadModule deflate_module modules/mod_deflate.so

Open httpd.conf file using a text editor and place the following in it:

# mod_deflate configuration
<IfModule mod_deflate.c>
 
# Restrict compression to these MIME types
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE text/css
 
# Level of compression (Highest 9 - Lowest 1)
DeflateCompressionLevel 9
 
# Netscape 4.x has some problems.
BrowserMatch ^Mozilla/4 gzip-only-text/html
 
# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\.0[678] no-gzip
 
# MSIE masquerades as Netscape, but it is fine
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
 
</IfModule>

and then retart the apache server

Now i use Gizp checker tool https://checkgzipcompression.com/, my website support Gizp, but when i use https://developers.google.com/speed/pagespeed/insights/ check speed of my website, google PageSpeed Insights show i need to enable Gzip compression, what's the problem?

I use https://nixcp.com/tools/gzip-test/, it is said my website does not support Gzip compression.

my Centos webpanel has install Varnish by select webservers->Apache & Varnish Cache & Nginx Reverse Proxy->Save& rebuild configuration

Pages: [1]