Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - AcemiPenguen

Pages: [1]
1
PostgreSQL / How can i install postgreSQL?
« on: August 11, 2020, 07:15:13 AM »
Hi,

i deleted postgres database and cannot use postgresql anymore. So, i uninstalled by terminal with this command

yum remove postgresql-server postgresql postgresql-devel

and when i open cwp admin page, postgresql installer, show click to install postgresql

and i try to install by web but its not working. not installing anything.

i can open phpgadmin page but its empty and cannot login there too.. please help..

2
CentOS 7 Problems / SQLSRV is not running
« on: May 08, 2020, 11:50:30 PM »
i try to open sqlsrv on php 7.3.17, clicked sqlsrv checkbox and rebuilded but not in list of info.. i tried all steps on cwp-wiki, all of success but still not working.. how can i install driver and run sqlsrv support on cwp?

3
CentOS 7 Problems / php ini not changing
« on: April 25, 2020, 11:43:59 PM »
hello,

I want to change my php ini settings about upload max filesize.
when i try to change on php simple editor or php.ini configurator, its look good but when i try to open php info, its not changing. which file need to change? whats problem about that?

 i try to change its 20 megs, but still lookin 2 megs.

4
CentOS 7 Problems / php-fpm not installed
« on: April 23, 2020, 10:28:02 PM »
hello,

i lost partition home and need to re-install my centos and cwp. now, i tried to change server apache&nginx&varnish but, nginx not starting. bcos, its always says that error,

Code: [Select]
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/inegoladsm.gov.tr.ssl.conf:148
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/intranet.inegoladsm.gov.tr.ssl.conf:9
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/intranet.inegoladsm.gov.tr.ssl.conf:74
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/intranet.inegoladsm.gov.tr.ssl.conf:111
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/intranet.inegoladsm.gov.tr.ssl.conf:148
Apr 24 02:14:21 cwp.inegoladsm.gov.tr nginx[9501]: nginx: [emerg] cannot load certificate "/etc/pki/tls/certs/intranet.inegoladsm.gov.tr.bundle": PEM_read_bio_X509_AUX() failed (SSL: error:0906D06C:PEM routines:PEM_read_bio:no start line:Expecting: TRUSTED CERTIFICATE)
Apr 24 02:14:21 cwp.inegoladsm.gov.tr systemd[1]: nginx.service: control process exited, code=exited status=1
Apr 24 02:14:21 cwp.inegoladsm.gov.tr systemd[1]: Failed to start nginx - high performance web server.
Apr 24 02:14:21 cwp.inegoladsm.gov.tr systemd[1]: Unit nginx.service entered failed state.
Apr 24 02:14:21 cwp.inegoladsm.gov.tr systemd[1]: nginx.service failed.

when i try to change webserver main cfg, show always everywhere php-fpm not install and directing php-fpm selector. its not workin on free version. always says cwppro required. how can i solve that problem?

5
E-Mail / cannot send but can receive mail
« on: April 01, 2018, 12:47:30 PM »
im using freedns on cwp

and sets like that

@                  A                  (my ip)
@                  MX        10    cwp.mydomain.com
@                  TXT               v=spf1 mx a
subdomain1   A                  (my ip)
cwp               A                  (my ip)
subdomain2   A                  (my ip)
subdomain3   A                  (my ip)
ftp                 A                  (my ip)
mail              A                   (my ip)
www             CNAME           @
_dmarc         TXT                v=DMARC1; p=none; rua=mailto:webmaster@mydomain.com


master.cf

added this line
2525         inet        n         -        n     -       -      smtpd

iptables added 2525 accept

forwarded 2525 port on modem to my server ip and open port check 2525 is success

when i try to send out mail, always queue and not complete to deliver. what shoud i do?

meanwhile, have two master.cf in server

first path
/etc/postfix/master.cf
and other way
/usr/libexec/postfix/master.cf

and i changed both of them 2525 inet line

please help..

6
CentOS-WebPanel Bugs / CWP Roundcube Bug
« on: March 07, 2018, 12:24:24 PM »
when the login roundcube, 500 server error

roundcube logs
thrown in /usr/local/cwpsrv/var/services/roundcube/program/lib/Roundcube/bootstrap.php on line 405
[07-Mar-2018 10:40:56 UTC] PHP Fatal error:  Uncaught Error: Class 'Net_IDNA2' not found in /usr/local/cwpsrv/var/services/roundcube/program/lib/Roundcube/bootstrap.php:405

boostrap.php

if (!function_exists('idn_to_ascii'))
{
    function idn_to_ascii($domain)
    {
        static $idn, $loaded;

        if (!$loaded) {
            $idn    = new Net_IDNA2();
            $loaded = true;
        }

        if ($idn && $domain && preg_match('/[^\x20-\x7E]/', $domain)) {
            try {
                $domain = $idn->encode($domain);
            }
            catch (Exception $e) {
            }
        }

        return $domain;
    }
}

bold line is problem line. no have this function on bootstrap.php

7
CentOS 7 Problems / Centos Web Panel Login Problem
« on: February 28, 2018, 08:49:10 PM »
Hi,

I installed centos 7 and cwp7 today. Its really so nice and easy panel. I like very much.

I created a domain and I have it on godaddy. When i try to change nameservers, its not working ns1.mydomain.com and ns2.mydomain.com and i try to use dns options and i can reach my server now.

when try to open mydomain.com:2082, opening login page. When i write username and pasword for domain, waiting login page. Cannot logging in. How can i solve that problem?

Another problem is mail server. I write my ip on free dns manager mail area. When i try to open mail.mydomain.com, opening homepage. Roundcube mail not opening. I try to open from cwp root panel but not working too. What should i do?

Last question, i created subdomain and its demo.mydomain.com but its not opening too..

thanks for help..

Pages: [1]