Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Freespirits_GR_Host

Pages: [1]
1
CentOS 7 Problems / cpanel is not working after CWP migration
« on: November 01, 2022, 12:03:48 PM »
I finished the migration normally for all my accounts.
I rebuild the vhosts for all my domains.
The problem is that after a total renovation of all the SSL certificates even though the webmail, mail, and ftp works normally the cpanel shows a  HTTP ERROR 500.
I tried to disable firewall, modescurity and remove the SSL for some of the accounts to test but again the problem is there.
Even a reboot did not fix the issue.
If i ping to cpanel.domain i get normally response but the panel won't open.
I tried to repair the user permission but again no luck.
Does anyone has any idea why that happened? I never had such and issue before.



2
CentOS-WebPanel Bugs / CWP to CWP mailbox migration issue
« on: October 17, 2022, 08:06:59 AM »
Hello

I migrated some accounts from one server to another but even if the mailbox was transferred and everything worked normally there is a critical issue.
1. The mailbox folders from the accounts are not recreated.
2. At the same time the contacts of all the mailboxes are lost and not migrated.

I tried to delete the migration and started again but i just had the same result.

3
CentOS-WebPanel Bugs / Shoutcast Won't connect
« on: May 24, 2022, 09:58:13 AM »
Hello

I have tested the new shoutcast plugin and works with autodj.
The problems are the following:

- If i try to connect with virtual dj when Autodj is playing i see the error "Stream in use"
- If i stop manually the autodj service and try to connect i see the error "Error.Disconected. Reconecting..."

Tested with Radio Caster and again i can't connect showing only status "connecting..."
I started 3 different servers and tested with same results.
I totally disabled firewall to be sure that it will not interfere even if i have opened the necessary ports and again i just can't use it.

Is there something i am missing?
Can someone test and confirm that server connection is not possible?


4
Updates / Problems with update 0.9.8.1136
« on: May 17, 2022, 11:01:48 PM »
1. After the last update all the versions of php added and enabled to panel.
2. Can't unistall any version (message an error occured)
3. Not able to edit version, button is not working anymore
4. If i try to stop a version that i never used it will start automatically after some seconds
5. Now 35% percentage of server's cpu is used and before the update server was idle with 1% used.

I believe that if the update is incomplete and not tested is better to stay away from a live server as those functions are critical.

Thank you in advance.

5
Updates / pwnkit exploit
« on: January 30, 2022, 01:40:05 PM »
Hello

I woud like to know if the security fix for the called "pwnkit" exploit is applied to CWP7 latest versions automatically or we have to run the following command to fix the issue to Centos distribution.

Code: [Select]
chmod 0755 /usr/bin/pkexec
Thank you in advance

6
Addons / New shoutcast + Icecast + Autodj
« on: January 03, 2022, 05:02:41 PM »
Hello guys. Wish a happy new year.

I checked the lastest updates that CWP7 team worked on new version of shoutcast, icecast and autodj module.
Change logs
https://control-webpanel.com/changelog#1621988246013-4dff7543-aab41

The problem is that at the moment i can't use any of those versions.
At the same moment we can spot all the new options under Plugins CWP7 main menu.
Is it still under development?
I guess there should be a notice about that very interesting addon  ;).

7
CentOS-WebPanel Bugs / 502 bad gateway adding new user
« on: December 16, 2021, 01:42:37 PM »
Hello

There is a bug when adding a new user showing 502 bad gateway.
Since now we could overtake this problem deleting the user webserver and then double the Process limit of the user.
After the latest updates even if we change "Process limit" or "Open files" and get a confirmation message there is no actual change so the above error will remain.
The only way for someone to overtake the problem and make the webserver to work normally is to use ftp and locate
Code: [Select]
/etc/security/limits.d and change user's limits there. Is enough to double the "Process limit" and then recreate the webserver.


Thank you in advance for any correction and fix that will take place :).
In the meantime the above solution will save sometime to CWP7 users :).

8
CentOS-WebPanel GUI / Copy files to another folder not working
« on: September 30, 2020, 05:43:15 PM »
Hello

After the latest change of the file explorer to the administrator panel it is not possible to complete the graphical copy files command.
There is an animation showing that there is a procedure but nothing is being coppied. 
On the other hand compress menu is working perfect and really improved to the latest updates.  ;)

Thank you and keep up the great job.

9
CentOS-WebPanel Bugs / Fix Account Permissions problem
« on: September 07, 2020, 02:42:45 AM »
Hello

I would like to report an issue after using the "Fix Account Permissions".
The fix does the following : chmod files to 644, php files to 640 and folders to 755.

The problem is that someone using Joomla and nginx as webserver using that option will have problems with the website showing "403 Forbidden" error because index.php gets the 640 permission.
Is it possible to have one more option to fix permissions having only the options to chmod files to 644 and folders to 755?

I spend a lot of time to find out that 640 permission added for php files and hope that this post will save some time to people trying to investigate "403 Forbidden error".

Thank you in advance.

10
CentOS 7 Problems / Proble with New editor after update
« on: May 27, 2020, 01:13:11 PM »
Hello

After the latest update with the new editor imported to CWP7 all the edited files through server gets messy.
Even editing the custom or original vhost files leades to corrupted files.
There seems to be an auto correct or maybe the editor saves files with own changes.

To reproduce the problem try to add a line to a nginx.conf file of a domain and save it.
Then try to restart nginx server and you will get a lot of random messages about this file and service will fail.

Thank you guys in advance. Keep up the great job.

11
CentOS Configuration / How to configure SpamAssassin
« on: March 09, 2020, 08:43:41 PM »
Hello

The "How to configure Spamassassin" section to wiki here --> https://wiki.centos-webpanel.com/how-to-configure-spamassassin is outdated.

So it would be great to be updated with the following or just update the configuration files locations mentioned there.

Step 1. Edit the configuration (/etc/mail/spamassassin/local.cf)  file with the settings below

Quote
required_hits 5
report_safe 0
required_score 5
rewrite_header Subject [***SPAM***]

Step 2. Edit  /etc/sysconfig/spamassassin file with below config (replacing everything in it) and save it

Code: [Select]
SAHOME="/var/lib/spamassassin/"
SPAMDOPTIONS="-d -c -m5 -H --username nobody -s ${SAHOME}spamd.log"

Step 3. Edit configuration file in Postfix. Open the file /etc/postfix/master.cf and edit/add the config below then save it.

Code: [Select]
smtp      inet  n       -       n       -       -       smtpd
  -o content_filter=smtp-amavis:127.0.0.1:10024
  -o receive_override_options=no_address_mappings
  -o content_filter=spamassassin

Code: [Select]
spamassassin      unix -      n      n      -      -      pipe
  user=nobody argv=/usr/bin/spamc -f -e
  /usr/sbin/sendmail -oi -f ${sender} ${recipient}

Step 4. Restart Postfix and SpamAssasin services

You are ready to go :)

Extra configuration tips

- In case you want mail to be deleted automaticaly and not receive the header rewritten with [***SPAM***] then you can set 

Code: [Select]
report_safe 1
to step 1.
 
- If you wish to make server more strict you can set the following flag lower. So 0 will always pass but if we set it to 3 that means a lot of mail will get flaged.

Code: [Select]
required_score 5
- One more configuration you could play is the following. The more you lower this value your mailserver will become strict.

Code: [Select]
required_hits 5

12
SSL / No SSL Install Please Wait
« on: March 05, 2020, 01:05:43 AM »
Hello

Suddenly the SSL certificate of my main domain stopped working.
Even if it was there the SSL was missing and had the error for not valid certificate from all browsers.

I removed the certificate and tried to add it again.
Through the Webserver settings --> SSL configuration i get the "Installing Please wait" message on button and that wasn't creating the certificate.

I disabled firewall, modsecurity but with no luck.
Ensure that post 443 is open.

Testing all the above i saw the new version loaded 0.9.8.948.

The next step was to try to load the SSL from the user panel and even if it stuck to "Installing" after 20 minutes i was surprised and of course relieved to see the ssl files created for the domain even though the "Installing"  status never changed.

Just wanted to report it as it seems to be related with the latest updates.

13
CentOS-WebPanel GUI / Not able to use compress
« on: February 29, 2020, 10:04:26 AM »
Hello

I have CWP7 pro installed to other servers too and can compress files.
To the last server i installed it when i try to compress my files from file manager i get the following error

Code: [Select]
I/O Error.
�&{��*��nnX��٥

Could you please help me with that?

Thank you in advance

14
SSL / Using ssl to secure soundcast stream
« on: February 21, 2020, 08:32:30 AM »
Hello.

I need to secure my ssl stream with https and have alreadytried using stunnel.

The problem is i can't locate the following certificates needed for configuration.

Code: [Select]
[shoutcast]
accept = 1234
connect = 1.2.3.4:8820
cert = /etc/letsencrypt/live/radio.domain.tld/fullchain.pem
key = /etc/letsencrypt/live/radio.domain.tld/privkey.pem

Could you please help on how i can get those keys from my domain that already has a Let's encrypt SSL certificate assigned?

The other method is to use the following order and create the stunnel.pem

rsa key first
certificate second
cabundle/intermediate third

I just can't figure out where to get those. I have already tested the keys from /etc/pki/tls/private/domain.tld.key

Thank you in advance

15
SSL / DNS of your domain doesn't point to this server to New Account
« on: February 18, 2020, 10:51:04 AM »
Hello

I am using the latest version and would like to confirm that there is an issue with the aussl.
If i create user with domain i can't issue a new ssl receiving the error

"DNS of your domain doesn't point to this server"

If i add domain to an existing acount everything works normal.

Thank you in advance and hope to save time from people fihting with the same issue.

Pages: [1]