Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Painkiller88

Pages: [1] 2
1
Updates / Add new language to Wordpress wizard in future updates
« on: May 12, 2021, 07:21:47 AM »
Hi,

It would be nice if you could add german as a additional selectable language to the Wordpress Wizard in the User Panel.
Most of my customers aren't able to handle simple english and it is also hard for some to install the german lang pack afterwards.

so would be cool to have german lang available in one of the next updates.

thanks

2
CentOS-WebPanel GUI / CWP7 UserPanel translation Problem
« on: May 12, 2021, 07:17:29 AM »
Hi,

i saw there were a few new updates and checked them, i recorgnized in the User Panel if you use German lang, there is a wrong translation on the WordPress Installer.

i recorgnized it at version 0.9.8.1061 but could be since 0.9.8.1060 where you added some features to the Wordpress Wizard.

Problem:

In the section advanced options you can enter the Username, Database and Password for the DB, but Password is translated to "Bestehen" instead of "Passwort" which would be the correct german translation.

So just something non important.

BTW: Would it be possible to add German as a selectable language for the Wizard, most of my customers can't speak a minimum english and have problems installing a german lang pack after setting up Wordpress  ;D


thanks

3
CentOS 7 Problems / fantastico_f3 in client area
« on: April 30, 2021, 11:05:42 AM »
I just updated to the new Version CWP7: 0.9.8.1057

Now i saw in my client are under script installers the normal softaculous and now something named fantastico_f3

If i click i get a spanish error message that the module isn't available.

I couldn't find any new modules to activate in the modules admin panel and nothing about this as a new feature is in the changelog.

All the existing old Posts about this are unanswered.

what is it

thanks.

4
CentOS 7 Problems / How to reset Users Bandwith Period
« on: April 07, 2021, 04:19:03 PM »
Hi,

How can i reset a Users Bandwith period? I want to have every User start from 1st of the month with his Bandwith limit.

I already tried to modify the limits in the package and update the quota, but nothing helped me to reset the bandwith.


Thanks

5
Updates / Error after updating Spamassassins to 3.4.4.8
« on: March 27, 2021, 08:45:55 PM »
Hi,

The version of spamassassin installed on CWP is outdated (3.4.0) so i did a manual update to 3.4.4.8 stable
also sa-update is not doing an update thats why i've done the manual update.

but after updating the service always failed to start (started and run into fail state)

so i needed to downgrade again.

Is there any chance to get an actual spamassassin or is there a specific reason why cwp has an old version in the repo?

thanks.


6
Backup / No way a user can restore backup in User Panel
« on: March 22, 2021, 04:39:12 PM »
It would be nice to have an option for Users to Restore their Backups.

There is no elegant way to do this, except of unzipping and overwriting the files and folders manually.

But there is no real restore option.

Could we have this in future versions?

7
CentOS Configuration / Change Users Ressource Period
« on: March 17, 2021, 10:25:44 PM »
Hi,

How can i change the period of a users ressources?

EG: I created a User in the middle of the month, now his period also goes till 15th.

He would like to have his month from 1st to last day. Any way i can change the date of the ressource reset?

Thanks.

8
CentOS 7 Problems / User Panel no longer accessable
« on: March 15, 2021, 06:58:43 AM »
I couldn't access my user panel so i tried a lot of things including restarting server and services a few times, changed weberver config from apache,nginx varnish to apacha, nginx but nothing worked.

I was able to get into the user panel in the users list direkt token link but not directly, not internally or externally.

Result:
---------------------------
This page isn’t working srv1.xxxx is currently unable to handle this request.
HTTP ERROR 500

--------------------------

So i couldn't fix it and made a fresh setup.

All fine for the first moment, i updated apache to the latest version and php to 7.4.16 (PHP-FPM)

checked User panel and it worked

After that i configured the mailserver etc. and now, User panel gone again.

i don't know whats wrong here but i made a fresh install and just did the initial config again, and it isn't the first time i set up CWP so i know how to do this.

This only happened since the latest CWP Pro .50 Update, i never had this before and suddenly 2 times, is there a Fix for this i don't wanna re setup everything again just to face the same Problem 1-3hours later again.

Can anyone reproduce this error and give a solution?

Thanks

9
CSF Firewall / How to get rid of UDP_IN Blocked message flood
« on: March 14, 2021, 11:14:34 PM »
Hi,

when i check the /var/log/messages file i see a lot of

Code: [Select]
ar 15 00:05:51 srv1 kernel: Firewall: *UDP_IN Blocked* IN=eno1 OUT= MAC=ff:ff:ff:ff:ff:ff:1c:6f:65:33:f0:7f:08:00 SRC=192.168.1.14 DST=192.168.1.255 LEN=49 TOS=0x00 PREC=0x00 TTL=128 ID=1446 PROTO=UDP SPT=50837 DPT=32412 LEN=29
Not just from the same source IP also from my other devices like the Samsung TV etc.

This seems to be the typically broadcast messages and it is ok for me, i just don't wanna see them every second in my logs because so i could miss important things.

How can i get rid of them?

Thanks

10
CentOS-WebPanel GUI / Security Center missing/broken flags
« on: March 13, 2021, 02:57:18 PM »
I recorgnized that some flags are not named correctly and show up as a broken image in the Security Panel where you can see the possible attackers flag.


So i just got a broken image instead of the flag.


eg:

Moldavia

in the path: /usr/local/cwpsrv/htdocs/admin/design/img/16/ there is a moldova.png

but expected is this filename: Moldova,-Republic-of.png

So i copied moldova.png and inserted the copy named as: Moldova,-Republic-of.png

i also recorgnized this with russia.

So instead of the country.png here the tooltip name was taken because this is exactly what pops up when you hover the flag.

I fixed this on my own the way i explained above, but i know on the next update this is possible undone.

So maybe this could be fixed in some future updates, it is not a big problem.

11
CentOS Configuration / How to limit Visits per month
« on: March 13, 2021, 02:46:11 PM »
On many hosters sites i see in the plans 10000 visits per month etc.

So i was wondering how can i limit a Package or a User to have a fixed amount on visits?

I haven't found this function till now.

Thanks

12
CentOS 7 Problems / Daily Spamassassin update reports error
« on: March 13, 2021, 08:18:08 AM »
Hi, seems the spamassassin source in the script is offline.

I see we have Version 3.4.0 but there is already 3.4.4 or 3.4.5 out

i get the daily mails from the update report and it tells me:

Code: [Select]
channel: no 'mirrors.sought.rules.yerp.org' record found, channel failed
13-Mär-2021 06:08:30: SpamAssassin: Unknown error code 3 from sa-update

Any way to fix this, i know we can play around and manually install and update spamassassin but i don't think this is what we should do, maybe there is a reason for the old version in the repo.

Maybe this could be fixed/updated in one of the CWP updates we get.

Thanks

13
CentOS-WebPanel Bugs / PHPMyAdmin not working from Userpanel
« on: March 09, 2021, 11:54:06 AM »
I recorgnized that the PhpMyAdmin isn't working from inside the user Panel if you don't open the CWP Admin Panel Port on your Router/Firewall

As the Link in the User Panel is the same like in the Admin Panel, it is only working if i open Admin Panel Port in Router/Firewall.

But for Security Reasons i don't wanna open the Admin Panel through the internet, so i just allow User Panel access, but PMA isn't working then.


Is there any workaround or already a fix for this?

Thanks

14
CentOS 7 Problems / File System Lock not working
« on: March 06, 2021, 04:16:36 PM »
Hi,

I recorgnized that the File System Lock is only working on the public_html folder of the main accounts domain.

If a User has more domains they are still unlocked.

eg:

Main Domain main.com -> there is the public_html folder, and it gets locked

All other domains which are in a seperate folder for each domain, they doesn't get locked.

So the File System Lock is not working properly in my opinion because only 1 Domain of many gets locked


15
CentOS 7 Problems / PHP Defender/snuffleupagus fecks up PHP
« on: March 01, 2021, 10:58:45 PM »
Hi,

The new feature within the security center (PHP Defender) with PHP-FPM 7.4 in my case on BASIC kills PHP

This results in contacting a Website and you just get a File to Download instead of the Site.

It is working for a while maybe a few hours an suddenly a minute later the error kicks in.

I found this Error Message in the PHP-FPM Selector Status for 7.4:

Code: [Select]
Started The PHP FastCGI Process Manager.
Mar 01 23:24:11 srv1.xxxx php-fpm[1046]: [01-Mar-2021 23:24:11] NOTICE: PHP message: PHP Fatal error:  [snuffleupagus][0.0.0.0][config][log] Could not open configuration file /usr/local/cwpsrv/htdocs/resources/admin/include/modules/security_center/defender_rules/cwp_php_defender_basic.rules : No such file or directory in Unknown on line 0

after restarting php it works again, but it took me some time to figure out whats wrong.

In PHP Defender you can see this for all domains on the Server:

Code: [Select]
Invalid configuration file
File: Unknown (0')
Action: config

This happened 2 times now on my CWP.

I uninstalled PHP Defender for now, maybe there is a bit more work to do before releasing it.

Again my details:

PHP-FPM 7.4
CWPpro version: 0.9.8.1048

thanks

Pages: [1] 2