Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Netino

Pages: 1 ... 15 16 [17]
241
I can build it / Re: Translate template to brazilian portuguese
« on: December 17, 2017, 01:40:54 AM »
Hello,
There is a module in the admin where you can edit, clone or create new languages, the path of this module is:

-> Admin Panel -> Plugins -> Themes and Languages -> Languages ->

Clone the English language first, and change the translation.
After, we can contribute with more translations.

242
How to / Re: how to create domain alias
« on: December 02, 2017, 07:53:07 PM »
To make an alias to your domain, you can use the ServerAlias directive of apache server, in the file '/usr/local/apache/conf.d/vhosts.conf'.

If you have, for example:
----------------------------------------------
ServerAlias domainexample.com
----------------------------------------------

you can manually edit to:
--------------------------------------------------------------------------------------
ServerAlias domainexample.com server2.domainexample.com
--------------------------------------------------------------------------------------

or:
------------------------------------------------------------------------------------------------------------------------------
ServerAlias domainexample.com server2.domainexample.com server3.domainexample.com
------------------------------------------------------------------------------------------------------------------------------

or:
------------------------------------------------------
ServerAlias *.domainexample.com
------------------------------------------------------
etc.

The only question I have is, if editing manually, the changes would be overwritten by changes made via panel, ou updates.

Regards,
Netino

243
How to / Re: how to create domain alias
« on: December 02, 2017, 07:35:42 PM »
The .htaccess simply is not an answer.
To apache interpret the .htaccess file, the access MUST be arrived at the server, within the path, to interpret this file fontent.
If the access of the alias domain already comes to a directory on the server, the .htaccess should be not needed anymore.

The question is exactly how to make the apache server direct the access of that domain alias to a directory on the server.

244
Updates / Re: Update for openSSL is important!
« on: December 01, 2017, 01:57:02 AM »
CWP is running a customized version of apache/mod_ssl (cwp-httpd).

Checking that version we discover:
---------------------------------------
# strings /usr/local/apache/modules/mod_ssl.so | egrep '^mod_ssl\/|^OpenSSL '
OpenSSL 1.0.1e 11 Feb 2013
OpenSSL 1.0.1e 11 Feb 2013
---------------------------------------

So, this update seems is a must update!
When we would have a updated version of CWP?

245
There are some problem with the pointing of the certificate.
I spend three days working on this.

The program creates correctly the certificates at '/etc/pki/tls/certs/', but the certificate directive in the file '/usr/local/cwpsrv/conf/cwpsrv.conf' with:
-----------------------------------------------------------
ssl_certificate     /etc/pki/tls/certs/hostname.crt;
-----------------------------------------------------------

when my server is working only with:
-----------------------------------------------------------
ssl_certificate     /etc/pki/tls/certs/hostname.bundle;
-----------------------------------------------------------

It's a bug..??!!

246
Ok, I've tried the following:
http://wiki.centos-webpanel.com/hostname-ssl-with-letsencrypt

but that page is not updated.

Seems the correct menu has changed:
Instead:
In cwp.admin left menu go to > CWP Settings > Change Hostname save there your hostname...

read:
In cwp.admin left menu go to > Server Settings > Change Hostname save there your hostname.

247
We have the option to ANY domain on that menu, but NOT to the main domain, the hostname domain.
(as 'hostname domain' I'm regarding the process to get the certificate from LetsEncrypt)

This was definitely disabled...??!!

There are videos on youtube, but this option simply don't work anymore like that.

248
Information / Re: install and configure Spamassassin
« on: September 03, 2017, 04:01:29 AM »
My SSD disk was fulfilled completely  in a week, with logfile '/spamfilter.log' (at root directory) with the logs like:
=================================================================
Thu Aug 17 00:05:54 2017 [27835] info: spamd: server successfully spawned child process, pid 27838
Thu Aug 17 00:05:54 2017 [27835] info: spamd: server successfully spawned child process, pid 27839
Thu Aug 17 00:05:54 2017 [27838] error: spamd: cannot run as nonexistent user or root with -u option
Thu Aug 17 00:05:54 2017 [27835] info: prefork: child states: SS
Thu Aug 17 00:05:54 2017 [27835] info: spamd: server successfully spawned child process, pid 27840
Thu Aug 17 00:05:54 2017 [27835] info: prefork: adjust: 0 idle children less than 1 minimum idle children. Increasing spamd children: 27840 started.
Thu Aug 17 00:05:54 2017 [27839] error: spamd: cannot run as nonexistent user or root with -u option
Thu Aug 17 00:05:54 2017 [27835] info: prefork: child states: SSS
Thu Aug 17 00:05:54 2017 [27835] info: spamd: server successfully spawned child process, pid 27841
Thu Aug 17 00:05:54 2017 [27835] info: prefork: adjust: 0 idle children less than 1 minimum idle children. Increasing spamd children: 27841 started.
=================================================================

Seems the criptical is the "error:" line, claiming "spamd: cannot run as nonexistent user or root with -u option".
I don't know where to correct it.

Regards,
Netino

249
CentOS-WebPanel Bugs / Re: clamd is stopped....
« on: August 16, 2017, 04:04:33 AM »
Seems clamd is trying to restart in a infinite loop.
Maybe is clashing with amavis trying to restart clamd too.
My solution was to stops clamd service at Dashboard.
Unfortunately, rebooting the server, needs to stops manually the clamd process.

Seeking the logs:
Aug 16 00:56:14 painel clamd[3342]: LOCAL: Socket file /var/run/clamd.amavisd/clamd.sock is in use by another process.
Aug 16 00:56:14 painel clamd[3360]: Received 0 file descriptor(s) from systemd.
Aug 16 00:56:14 painel clamd[3360]: clamd daemon 0.99.2 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Aug 16 00:56:14 painel clamd[3360]: Running as user amavis (UID 990, GID 989)
Aug 16 00:56:14 painel clamd[3360]: Log file size limited to 1048576 bytes.
Aug 16 00:56:14 painel clamd[3360]: Reading databases from /var/lib/clamav
Aug 16 00:56:14 painel clamd[3360]: Not loading PUA signatures.
Aug 16 00:56:14 painel clamd[3360]: Bytecode: Security mode set to "TrustSigned".
Aug 16 00:56:19 painel clamd[3360]: Loaded 6321412 signatures.
Aug 16 00:56:20 painel clamd[3360]: LOCAL: Socket file /var/run/clamd.amavisd/clamd.sock is in use by another process.
Aug 16 00:56:21 painel clamd[3491]: Received 0 file descriptor(s) from systemd.
Aug 16 00:56:21 painel clamd[3491]: clamd daemon 0.99.2 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Aug 16 00:56:21 painel clamd[3491]: Running as user amavis (UID 990, GID 989)
Aug 16 00:56:21 painel clamd[3491]: Log file size limited to 1048576 bytes.
Aug 16 00:56:21 painel clamd[3491]: Reading databases from /var/lib/clamav
Aug 16 00:56:21 painel clamd[3491]: Not loading PUA signatures.
Aug 16 00:56:21 painel clamd[3491]: Bytecode: Security mode set to "TrustSigned".
Aug 16 00:56:25 painel clamd[3491]: Loaded 6321412 signatures.
Aug 16 00:56:27 painel clamd[3491]: LOCAL: Socket file /var/run/clamd.amavisd/clamd.sock is in use by another process.
(...)

250
New Modules / Re: Reseller Account
« on: July 09, 2017, 05:32:53 PM »
Is the security of this module thought in this same way too?

251
New Modules / Re: Reseller Account
« on: July 08, 2017, 06:47:32 PM »
A reseller account would not be dependent of a domain.
If  that domain would dropped for any reason, the account will rest inconsistent.

252
Backup / Re: backup access rights (all users can access)
« on: July 08, 2017, 06:06:16 PM »
I second this change.
I right now test, and my server has this problem too.

253
Backup / Re: Remote backup not working
« on: July 08, 2017, 05:45:54 PM »
Someone get the solution..??!!

I'm having the problem:
(...)
Database Backup: mysql --> /backup/mysql/daily//mysql.sql
mysqldump: Got error: 1142: "SELECT, LOCK TABLES command denied to user 'root'@'localhost' for table 'accounts'" when using LOCK TABLES
(...)

Regards,
Netino

254
I can build it / Re: OpenVZ with CWP
« on: July 06, 2017, 05:21:23 PM »
(...)
I don`t agree with that since I saw a post in the forum that somebody want to change the logo of CWP and I don`t like that when somebody is offering something good to you for free you want to change logo/copyright to sign it on your name.
(...)

I think this is the purpose of "brands".
You can brand anything copyrighted.

Don't forget you are posting in a forum, branded with "SMF - Simple Machines Forum", but the SMF software allows perfectly to use the logo AND the signature of CWP.

Pages: 1 ... 15 16 [17]