Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - fredo

Pages: 1 2 [3] 4
31
Installation / CWP install on CentOS 7.x without MARIA DB as default
« on: April 08, 2017, 11:49:40 PM »
Hi, I opened this topic hopping that someone could advice the many users that wanted to install CWP on Centos 6.x or CentOS 7.x
WITHOUT Maria db as default...

Ive read many topics regarding this... but eveyone who tried to uninstall maria db (as suggested for CWP staff) and then install MySQL 5.6 o 5.7 had many issues on CWP..

So, did someone achieved this? did someone uninstall Maria DB properly and sucessfully install MySQL 5.6 o 5.7?

could someone help?


Thanks!

32
MySQL / Re: CWP CentOS 7 installer with MySQL without MariaDB
« on: April 08, 2017, 11:31:24 PM »
OMG I'm facing this problemtoo ! How come you guys drop support MySQL and replace it by MariaDB ! this is wrong move though.
All my database is in MySQL version 5.7 and it's not easy to convert to MariaDB !

Quote
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'json DEFAULT NULL,

I removed Mariadb, installed MySQL 5.7, and got many weird errors in CWP (on browser)

http://prnt.sc/eolgxk

Hi locvfx,
where you able to fix it? where u able to install cwp on centos 7 with mysql 5.6 o 5.7?
cheers


33
MySQL / Re: CWP INSTALL without MARIADB as default
« on: April 07, 2017, 08:20:20 PM »
you can manually install mysql by removing mariadb

Not compatible!

http://prnt.sc/eolgxk , and may other errors in CWP version: 0.9.8.196  + MySQL 5.7

Hi,locvfx

but where you able to install mysql 5.6 or 5.7 some how?

Cheers!

34
CentOS 6 Problems / Re: CentOS6 Upgrade
« on: April 06, 2017, 10:28:50 PM »
And on the login page:2030/login.php 404 error

Stopping cwpsrvd:                                          [FAILED]
Starting cwpsrvd: (98)Address already in use: make_sock: could not bind to address [::]:2030
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:2030
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

What now???
any ideas?

have you tried to kill the process and/or do a simple reboot of the server ?

Yes! i did it several times, but the pid for cwp was always running... only rebooting the server stoped it!

For all
All issues you are reporting can be done by running rebuild of the cwp-httpd and rebuild of the vhosts from cwp, all you need is to read logs.
http://wiki.centos-webpanel.com/service-log-paths

at that moment couldt get cwp to work and all the sites where down logically.. tried restore and didn't work out..
thats why did a "clean" install..

35
CentOS 6 Problems / Re: CentOS6 Upgrade
« on: April 06, 2017, 06:15:14 PM »
Well.. Ive got lucky..

As mentioned before, I couldnt do a cwpserver restore after I tried to update my cwp 0.0.8.14 to newer version..
so after severall atempts to make it work.. I decide an extreme mesure..
made another backup of DDBB of my domains, and domains and copy on another directory..
then... I made a "clean" install using sh cwa-latest

It worked out! I thought I had to reinstall mysql and recreate domains and stuff.. but to my surprise..everything was there...
working..and with CWP version: 0.9.8.17 ! (i had 0.9.8.14)

guess Ive been lucky..

 




36
CentOS 6 Problems / Re: CentOS6 Upgrade
« on: April 06, 2017, 05:09:25 PM »
another server..another problem... this is really a mess!!
mysql 5.6.30 was installed.. now when I ran the cwp update script..it shows this...

  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/images/ui-icons_888888_256x240.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/images/ui-icons_cd0a0a_256x240.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/jquery-ui-1.11.4.css
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/layout.inc.php
 extracting: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/screen.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/sprites.lib.php
  inflating: phpMyAdmin-4.6.6-all-languages/themes/sprites.css.php
  inflating: phpMyAdmin-4.6.6-all-languages/themes/svg_gradient.php
  inflating: phpMyAdmin-4.6.6-all-languages/transformation_overview.php
  inflating: phpMyAdmin-4.6.6-all-languages/transformation_wrapper.php
  inflating: phpMyAdmin-4.6.6-all-languages/url.php
  inflating: phpMyAdmin-4.6.6-all-languages/user_password.php
  inflating: phpMyAdmin-4.6.6-all-languages/version_check.php
  inflating: phpMyAdmin-4.6.6-all-languages/view_create.php
  inflating: phpMyAdmin-4.6.6-all-languages/view_operations.php

Seems like something went wrong
If you have problem with CWP try run cwpsrv.sh.1 restore

I Ran cwpsrv.sh.1 restore

Removed:
  cwpphp.x86_64 0:7.0.17-1               cwpsrv.x86_64 0:1.10.2-4

Complete!
Stopping cwpsrvd:                                          [FAILED]
Starting cwpsrvd: (98)Address already in use: make_sock: could not bind to address [::]:2030
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:2030
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

What now???
any ideas?

37
CentOS 6 Problems / Re: CentOS6 Upgrade
« on: April 05, 2017, 04:09:44 PM »
Almost a tragedy...

Before I made any upgrade, Ive checked everything that it was suggested on the tutorial..
then..
Ive upgraded cwp with the script provided...and it really went ok..
then.. Ive did the same with apache... but there...all the problems started...

1st of all ive got an "Unexpected EOF while looking for matching on apache.sh line 137
then in line 144 got Unexpected token " " in conditional command on apache.sh
then in line 146, syntax error: unexpected end of file..

there the script dies..

first I thought that it had to do with the download of the script..so Ive downloaded againg..and started all over..
but with same result..
and for the worst..apache was down.. each time Ive started I got this error..
"Starting httpd: AH0526: Syntax error in line 66 /usr/local/apache/conf/httpd.conf "
" invalid command 'User', perhaps misspeled or defined blah bla.."

so Ive made sh apache.sh restore...

once it finished... apache was running againg.. but when ive tried to check my webpage... got a 500 error :- (
checked apache error log...
it said " Couldnt create child process /usr/local/sbin/suphp for /home/mywebsite/public_html/index.php

then it added a Warning: SuexecUserGroup directive requires SUEXEC Wrapper..

so, the apache restore was not totally successfull

looked for a solution on google.. but it was useless..

Ive entered cwp panel on port 2030
went to apache rebuild... and then I saw that I could try for an Apache/2.4.25 rebuild..
did that..
and fortunatelly it went ok..
once it finished check my domain again...
and.. ooooppss Error 500 once more...
checked againg apache error logs...
the error changed...it says "[ core:alert] [pid xxxxx:xxxxxx] [client xxxxxxx:xxxx] /home/mywebsite/public_html/.htaccess Unknown filter provider DEFLATE

well that was not totally a disaster... went back to CWP to apache configuration
looked for mod_deflate
found it! it was commented. so took out the #
save the config..

although it showed that apache was restated.. my website still showed error 500...
so, once more checked the apache error log, it showed the same..
so using ssh Ive restarted apache..
and Finally got my webpage back!!

So, Ive made this thread to show you that there is a problem with the apache.sh file.. hopefully CWP staff can fix it..
also the restore for apache...

so hope this helps..

regards

38
Installation / Re: fresh instal with MySQL
« on: March 17, 2017, 05:04:29 PM »
Hi Sandeep,
You might be right, but some of us would be really thankfull if we had the option to choose between them.. as once happened with Mariadb.. thats all

thanks

39
MySQL / Re: CWP INSTALL without MARIADB as default
« on: March 17, 2017, 04:42:47 PM »
hi Sandeep!

Ive tried what was suggested in this topic.." CWP CentOS 7 installer with MySQL without MariaDB  (Read 201 times)"

but Ive made a mess! cause I did same as erntesky...
"The following command uninstall the MariaDB, but made conflicts with MySQL installer:
Code: [Select]
yum remove MariaDB MariaDB-server

This command totaly delete the MariaDB but straight killed the server: (Removed other important thinks as well...)
Code: [Select]
yum remove MariaDB MariaDB-server MariaDB-common MariaDB-shared

How I have to uninstall properly / totally MariaDB?"

so, after that I had to reinstall server... if you can provide the steps to unistall maria properly would be great..

Thnks!

40
MySQL / Re: CWP INSTALL without MARIADB as default
« on: March 17, 2017, 03:25:31 PM »
For those who like me, needed CWP With Mysql and NOT Mariadb, I was able to do it, by using an "old" cwp-latest file that I had from a server Ive installed 3 weeks ago.. Ive just copied the file from the "old" server to the new one.. and It worked out.. unfortunatelly I dont have cwp-latest for a CentOs 7.x  Does anybody?

It would be very appreciated if cwp would offer the option to install Mysql instead of Mariadb in Centos 6.x and Centos 7.x Just like they did for Mariadb before..

could it be possible?

Thanks..

41
Installation / Re: fresh instal with MySQL
« on: March 17, 2017, 03:23:21 PM »
For those who like me, needed CWP With Mysql and NOT Mariadb, I was able to do it, by using an "old" cwp-latest file that I had from a server Ive installed 3 weeks ago.. Ive just copied the file from the "old" server to the new one.. and It worked out.. unfortunatelly I dont have cwp-latest for a CentOs 7.x  Does anybody?

It would be very appreciated if cwp would offer the option to install Mysql instead of Mariadb in Centos 6.x and Centos 7.x Just like they did for Mariadb before..

could it be possible?

Thanks..

42
Installation / fresh instal with MySQL
« on: March 17, 2017, 12:32:07 PM »
Hi,
Ive installed yesterday a CWP in new server, and found out that Mariadb was installed instead of Mysql, I understand that this is the default now.. but unfortunatelly, I really need to deliver some servers with mysql..and not maria.. is there a way to install CWP with MySQL, can anyone assist?

Thanks.

43
MySQL / Re: CWP CentOS 7 installer with MySQL without MariaDB
« on: March 17, 2017, 12:13:01 AM »
im sorry, but where are these users and databases located? i've tryed :
yum remove MariaDB MariaDB-server

then tryed to install mysql but it installed again mariadb.. is there a tutorial or something?
really need cwp w mysql..

please help!

44
MySQL / CWP INSTALL without MARIADB as default
« on: March 16, 2017, 11:35:19 PM »
Hi,
Ive found out that new installations comes with mariadb as default... is there a way that we can do a fresh install WITHOUT MARIAdB? I'have a few costumers that are not pleased with this.. is there a step by step guide to install mysql instead of mariadb or is there a way to uninstall Mariadb and install mysql 5.6 instead?

Thanks in advance.

fredo

 

45
How to / how to create domain alias
« on: October 26, 2016, 05:10:58 PM »
Hi,

Ive been using CWP for a while.. I have a simple question though..

I have a DOMAIN.COM which is the main domain..

And I have DOMAIN.COM.XX which I want to be redirected to DOMAIN.COM.

How can I do that? could someone help me out? should I create a new domain and add .htaccess? or CWP provide a tool manage site redirection? if so, where is it?

Thanks!


Pages: 1 2 [3] 4