Author Topic: Cant add autoresponder  (Read 1806 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Cant add autoresponder
« on: January 05, 2021, 12:09:51 AM »
I have CWP pro, and cant add autoresponders after updating.

As a root user in the main control panel, when I click to add an autoreponder, a red popup appears saying: "FATAL ERROR error writing to DB".

When I try adding an autoresponder via the user control panel, the list of autoreponders just doesnt load (stays blank).

I tried this advice on another thread:

Quote
Before update you can using next fix:
chown postfix /usr/local/cwpsrv/htdocs/resources/admin/include/postfix.php
chmod 644 /usr/local/cwpsrv/htdocs/resources/admin/include/postfix.php
chattr +i /usr/local/cwpsrv/htdocs/resources/admin/include/postfix.php

It didnt work. I assume this was just to use these commands via ssh, which is what I did.

Offline
*
Re: Cant add autoresponder
« Reply #1 on: July 27, 2021, 10:00:45 PM »
It's a shame that 6 months later, this hasn't been fixed. I am having the same issues. Were you able to fix this? I tried the above lines but no luck.
« Last Edit: July 27, 2021, 10:06:47 PM by tg040 »

Offline
**
Re: Cant add autoresponder
« Reply #2 on: July 29, 2021, 09:23:46 PM »
My autoresponder works fine.  But keep in mind you have to have the email account created and visible in your list of email accounts.   Forwarding domains can cause autoresponder problems.
Listen to everything Pixelpadre says.

Offline
*
Re: Cant add autoresponder
« Reply #3 on: August 29, 2021, 09:46:53 AM »
Hello, to create the autoresponder I have to do it as root from the CWP panel.
If I have already created an autoresponder and I want to modify it, I get a DB error.
If the client tries to do it from his panel, he also gets a DB error.
So I don't know where is the failure, let's see if someone @admin answers the doubts.