Author Topic: MariaDB update failed  (Read 13504 times)

0 Members and 1 Guest are viewing this topic.

Re: MariaDB update failed
« Reply #15 on: December 10, 2020, 08:48:46 PM »

I followed your how to on how to upgrade MariaDB following this instruction set:

It worked, thanks for the support you give it is the best IMHO

Now I have this issue in CWP admin (using CWPpro) in the  services status panel it displays "MySQL Database Server" = failed

"The status log reads:  InnoDB: Unable to lock ./ibdata1 error: 11
[Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files."

How does one go about clearing this up?

Running on CentOS 7.5

Re: MariaDB update failed
« Reply #16 on: December 10, 2020, 08:49:57 PM »
Hi, I do not think somebody can help you on the forum. There are too many reasons and the problem must be checked by a system administrator.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
Join our Development Team and get paid !

Installation Instructions
Get Fast Support Here

Re: MariaDB update failed
« Reply #17 on: December 11, 2020, 05:07:18 AM »

Go thru the steps again, make sure NOT to miss one or else it will mess everything up.
Especially Step 2. You want to follow the 2nd step labeled "For MariaDB 10.0/10.1/10.2/10.3 :", and NOT the 1st one.

I've used this guide on multiple servers, never had a problem.
If it still doesn't work. I agree with Igor, you'll have to have CWP support look at it.

CentOS 8 is a little easier, it has 10.4 by default.
You create the repo for 10.5, run dnf update and BAM that's it.

Re: MariaDB update failed
« Reply #18 on: January 13, 2021, 07:28:42 AM »
Upgrade successful

But my email smtp giving error when sending email

SMTP 451. Failed to add recipient.

Server configuration problem.

Please help

Here is the solution I found:

First step to save your database (I didn't do it!)

Code: [Select]
mysqldump --all-databases > /home/fullbackup.sql.gz
Uninstall MariaDB client:

Code: [Select]
yum remove MariaDB-server MariaDB-client -y
Now install MariaDB, it will automatically install MariaDB 10.2 (10.2.36):

Code: [Select]
yum install MariaDB-server MariaDB-client -y
Then to finish:

Code: [Select]