Author Topic: Hostname SSL Lets Encrypt  (Read 2187 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hostname SSL Lets Encrypt
« on: January 25, 2021, 11:30:12 PM »
I am trying to get the hostname to get a let's encrypt SSL, but I can't get it to work.
I have a record setup, but I am not using local dns I am using Cloudflare
« Last Edit: January 25, 2021, 11:35:47 PM by rda1990 »

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #1 on: January 26, 2021, 09:01:13 PM »
if you are using cloudfare then disable the proxy for the A record for the hostname

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #2 on: January 27, 2021, 07:02:15 AM »
I do not have proxy turned on.

I am getting this error on the change hostname page (Host Name) and it resolves to IP: ; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.3 <<>> A (Host Name) +short @8.8.8.8 ;; global options: +cmd ;; connection timed out; no servers could be reached

I am on a pfsense firewall. With local dhcp routed to dedicated ips

if you are using cloudfare then disable the proxy for the A record for the hostname
« Last Edit: January 27, 2021, 07:11:20 AM by rda1990 »

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #3 on: January 27, 2021, 05:44:47 PM »
pfsense have this known issues. COntact pfsense for more detailed debug and issue resolving.

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #4 on: January 27, 2021, 09:05:35 PM »
pfsense have this known issues. COntact pfsense for more detailed debug and issue resolving.

What is the problem with CWP Control Web Panel since all other programs thatI am running with lets encrypt, I also use cpanel and dont have this problem.

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #5 on: January 27, 2021, 11:38:47 PM »
I do not have proxy turned on.

I am getting this error on the change hostname page (Host Name) and it resolves to IP: ; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.3 <<>> A (Host Name) +short @8.8.8.8 ;; global options: +cmd ;; connection timed out; no servers could be reached

I am on a pfsense firewall. With local dhcp routed to dedicated ips

if you are using cloudfare then disable the proxy for the A record for the hostname

I got this error fix but it will not make a lets encrypt ssl for the host name still

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #6 on: January 28, 2021, 11:42:27 AM »
check the autossl log in /root/.acme.sh/acme.sh.log

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #7 on: January 28, 2021, 03:00:01 PM »
I have been looking for that but nothing there is no folder in root with that when i server the system nothing

check the autossl log in /root/.acme.sh/acme.sh.log
« Last Edit: January 28, 2021, 03:05:03 PM by rda1990 »

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #8 on: January 28, 2021, 05:42:33 PM »
you've issues with network configurations. We didn't look into this issues.

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #9 on: January 28, 2021, 06:02:14 PM »
Where is the log at on the system that tells me what the system is doning, and it is not a networking problem since the only thing on my network that is having problems is this software.

you've issues with network configurations. We didn't look into this issues.

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #10 on: January 28, 2021, 08:20:31 PM »
check this output :
curl -I https://www.google.com/

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #11 on: January 29, 2021, 01:04:45 AM »
HTTP/1.1 200 OK
Content-Type: text/html; charset=ISO-8859-1
P3P: CP="This is not a P3P policy! See g.co/p3phelp for more info."
Date: Fri, 29 Jan 2021 01:04:07 GMT
Server: gws
X-XSS-Protection: 0
X-Frame-Options: SAMEORIGIN
Transfer-Encoding: chunked
Expires: Fri, 29 Jan 2021 01:04:07 GMT
Cache-Control: private
Set-Cookie: 1P_JAR=2021-01-29-01; expires=Sun, 28-Feb-2021 01:04:07 GMT; path=/; domain=.google.com; Secure
Set-Cookie: NID=208=DaLRKWhcwL2r3XwPNaSbqDqGhMczkaLjSUO4KwyyHpnAL5dMK7POJWXiXCzwWHbl6vjF2Ch6VJFb0HKqsrffY9rub3rYZK618SyG9oiRMmrFx8XfrjL-J746kLYJ-1TCba6Q5dsO7N979iJLh-vlmMPDLN10sg1AMYUxBYmzY-8; expires=Sat, 31-Jul-2021 01:04:07 GMT; path=/; domain=.google.com; HttpOnly
Alt-Svc: h3-29=":443"; ma=2592000,h3-T051=":443"; ma=2592000,h3-Q050=":443"; ma=2592000,h3-Q046=":443"; ma=2592000,h3-Q043=":443"; ma=2592000,quic=":443"; ma=2592000; v="46,43"


check this output :
curl -I https://www.google.com/

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #12 on: January 29, 2021, 04:00:11 AM »
ok seems good

you still missing the autossl log file ? /root/.acme.sh/acme.sh.log

Offline
*
Re: Hostname SSL Lets Encrypt
« Reply #13 on: January 29, 2021, 05:33:21 AM »
yes, I do not have the log file /root/.acme.sh missing
ok seems good

you still missing the autossl log file ? /root/.acme.sh/acme.sh.log

Offline
*****
Re: Hostname SSL Lets Encrypt
« Reply #14 on: February 01, 2021, 09:40:34 AM »
it seems like you have broken some things. Try to use the support: https://support.centos-webpanel.com
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services