Author Topic: BIND service doesn't load  (Read 456 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
BIND service doesn't load
« on: February 06, 2021, 10:04:12 PM »
Hello,

can someone help me please, I am trying to restart Bind service, but it doesnt restart, I get this error

Job for named.service failed because the control process exited with error code. See "systemctl status named.service" and "journalctl -xe" for details.


When checking the status, it shows this:

● named.service - Berkeley Internet Name Domain (DNS)
   Loaded: loaded (/usr/lib/systemd/system/named.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2021-02-06 17:02:16 EST; 1min 34s ago
  Process: 7562 ExecStop=/bin/sh -c /usr/sbin/rndc stop > /dev/null 2>&1 || /bin/kill -TERM $MAINPID (code=exited, status=0/SUCCESS)
  Process: 30259 ExecStart=/usr/sbin/named -u named -c ${NAMEDCONF} $OPTIONS (code=exited, status=0/SUCCESS)
  Process: 13724 ExecStartPre=/bin/bash -c if [ ! "$DISABLE_ZONE_CHECKING" == "yes" ]; then /usr/sbin/named-checkconf -z "$NAMEDCONF"; else echo "Checking of zone files is disabled"; fi (code=exited, status=1/FAILURE)
 Main PID: 30261 (code=exited, status=0/SUCCESS)

Feb 06 17:02:16 panel.moealdeek.com bash[13724]: zone moealdeek.com/IN: not loaded due to errors.
Feb 06 17:02:16 panel.moealdeek.com bash[13724]: _default/moealdeek.com/IN: bad zone
Feb 06 17:02:16 panel.moealdeek.com bash[13724]: zone haddadfaris.com/IN: loaded serial 2021020592
Feb 06 17:02:16 panel.moealdeek.com bash[13724]: zone panel.moealdeek.com/IN: loaded serial 2021020673
Feb 06 17:02:16 panel.moealdeek.com bash[13724]: zone ns1.moealdeek.com/IN: loaded serial 2013071600
Feb 06 17:02:16 panel.moealdeek.com bash[13724]: zone ns2.moealdeek.com/IN: loaded serial 2013071600
Feb 06 17:02:16 panel.moealdeek.com systemd[1]: named.service: control process exited, code=exited status=1
Feb 06 17:02:16 panel.moealdeek.com systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
Feb 06 17:02:16 panel.moealdeek.com systemd[1]: Unit named.service entered failed state.
Feb 06 17:02:16 panel.moealdeek.com systemd[1]: named.service failed.

Offline
*
Re: BIND service doesn't load
« Reply #1 on: February 07, 2021, 03:31:15 PM »
SOLVED by restarting the ns1 host