Author Topic: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2  (Read 2499 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Failed loading /usr/local/ioncube/ioncube_loader_lin_8.0.so:  /usr/local/ioncube/ioncube_loader_lin_8.0.so: cannot open shared object file: No such file or directory
PHP Warning:  Missing arginfo for uploadprogress_get_info() in Unknown on line 0
PHP Warning:  Missing arginfo for uploadprogress_get_contents() in Unknown on line 0

The ioncube loader is not even getting written to usr/local/ioncube/ --> it is missing

I am not sure why uploadprogress is not being compiled but it's not.

Can the developers please look into this, ioncube is a necessity for certain web applications like WHMCS and so on. (Oh and CWP 7!)

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #1 on: March 03, 2021, 10:20:30 PM »
Did you select ioncube when you compiled PHP?

PHP Selector 2 under the CWP Root Menu, or PHP FPM Selector if you have a pro license
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #2 on: March 03, 2021, 11:17:05 PM »
Yes I did and it didn't install it. - That's the problem...

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #3 on: March 03, 2021, 11:20:37 PM »
Which option are you using?

PHP Switcher or FPM?
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #4 on: March 04, 2021, 12:01:59 AM »
PHP-FPM Selector (NEW)

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #5 on: March 04, 2021, 12:51:26 AM »
can you put a file in the user account with just these lines
Code: [Select]
<?php
phpinfo
();
?>

also
Webserver Settings -> Webservers Main Config, Nginx/Apache (Which one you use) default PHP-FPM version

Webserver Settings-> Webservers Domain Config, tell me what it says for the users config files
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #6 on: March 04, 2021, 01:42:09 AM »
rcschaff IT'S NOT THERE. Just like the original post says. It (ioncube_loader_lin_8.0.so) is not in the /usr/local/ioncube folder - older versions are but 8.0 is not. Posting a phpinfo.php is only going to show you that in that section of the page Ioncube is not loaded. 
 ...and the forums won't let me insert an image here, go look at:

https://photos.google.com/search/_tra_/photo/AF1QipMbF-4_IPYTrntRq8J0O5o6TdMWYv9s60J1adYF

See it is NOT THERE. It is installing the .ini but not the module - that's why the error came up it is trying to load a module that is not there...

https://photos.google.com/search/_tra_/photo/AF1QipPtfSUVPMlgxoFk1yV9gEFFCCgexPfqg229lreb


Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #7 on: March 04, 2021, 01:47:47 AM »
Webserver Settings-> Webservers Domain Config

Is set to apache>php-fpm

PHP-FPM version: 8.0

This setting overrides the other setting you asked for...

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #8 on: March 04, 2021, 02:30:56 AM »
I'm sorry I am just frustrated that the developers don't double-check their work is all. And this isn't the first time for ioncube loader not to be installed with a PHP recompile. I had it hose a CWP server because it didn't install ioncube for CWP.

And we aren't even talking about the missing uploadprogresss installation either.

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #9 on: March 04, 2021, 03:30:16 AM »
I just now noticed from my own phpinfo that "imagick" is not installed either and it is surely selected in the settings. Come on guys and gals...

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #10 on: March 04, 2021, 03:50:06 AM »
uploadprogress IS showing up in the phpinfo as version 1.1.3 but there is some mystery problem that has PHP throwing an error over it - maybe a misconfiguration somewhere. The file:

/opt/alt/php-fpm80/usr/php/php.d/uploadprogress.ini

Seems OK. "extension=uploadprogress.so" --> which should be right...
I don't know but it throws an error when I try to use the PHP CLI executable.

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #11 on: March 04, 2021, 07:12:38 PM »
You failed to mention that you were trying to run in via CLI in the original post.  the CLI version php uses,is the system install php (Which is v5.6 or v7.1 by default).

If your trying to run php cli, you need to specify the full path the the php version that has the modules compiled. 

Ex:  /opt/alt/php-fpm71/usr/bin/php -v
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #12 on: March 04, 2021, 11:53:12 PM »
You take me for a fool Sir. I specified the path to the php-fpm PHP executable in:

sudo -u accountusername /opt/alt/php-fpm80/usr/bin/php ./command goes here

Why are you arguing with me over this? Can you not see the missing ioncube module that is getting called by ioncube.ini (/opt/alt/php-fpm80/usr/php/php.d/ioncube.ini) in my image? There is no "ioncube_loader_lin_8.0.so" (or ioncube_loader_lin_8.0_ts.so either...) present in the folder. So naturally it's not showing up in phpinfo.php. What gives? I have over 40 years doing this...

Then there's a problem with uploadprogress and no imagick installation either. All of this is visible in my posts. You have asked me a question that was answered by the title of my post even! If you are a dev for the project I see why there are problems.

Is this plain enough for you? Here are the contents of the ioncube.ini file. Show me where that is (not) in the folder...

zend_extension=/usr/local/ioncube/ioncube_loader_lin_8.0.so
« Last Edit: March 04, 2021, 11:59:12 PM by DA_MAN »

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #13 on: March 05, 2021, 12:41:22 AM »
Thank you for your rude reply.  I am neither a dev, nor staff of any kind.  Just someone willing to help you out.  If you have over 40 years of doing this, fix it yourself, and don't come on a forum begging for answers.  After all, you're smart enough to manually install ioncube yourself...

If you're reporting a bug, that different.  But DO NOT get condescending with people who are simply asking for more information/ giving advice.  Good luck to you.
Google Hangouts:  rcschaff82@gmail.com

Offline
***
Re: ioncube 8.0 and uploadprogress not being compiled in php-fpm 8.0.2
« Reply #14 on: March 05, 2021, 01:58:57 AM »
Just an FYI.  There is no loader for PHP 8, because ioncube has not made a loader for php8 as of yet.  Just checked the site myself, as I have a license.   When one becomes available, I'm sure CWP will include it.

The uploadprogress extension works on PHP 5, PHP 7, and PHP 8. It requires the use of the Apache HTTP Server with mod_php. Other web servers and PHP-FPM are not yet supported.
« Last Edit: March 05, 2021, 02:56:49 AM by rcschaff »
Google Hangouts:  rcschaff82@gmail.com