Author Topic: php 7.4 compile fails due to libzip  (Read 486 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
php 7.4 compile fails due to libzip
« on: March 27, 2021, 07:49:22 PM »
trying to change version of php from 7.2 to 7.4 and getting a missing package error:

checking for libzip >= 0.11... no
configure: error: Package requirements (libzip >= 0.11) were not met:

Package 'libzip', required by 'virtual:world', not found

-------
i already installed libzip and libzip-devel and still getting this error

Offline
*
Re: php 7.4 compile fails due to libzip
« Reply #1 on: April 30, 2021, 10:22:26 AM »
Hi,

PHP 7.4. is used as the primary PHP version on my server with CWP (free version) and

Code: [Select]
rpm -qa| grep zip
shows the following "zip" related packages:

Code: [Select]
unzip-6.0-21.el7.x86_64
gzip-1.5-10.el7.x86_64
bzip2-devel-1.0.6-13.el7.x86_64
p7zip-plugins-16.02-10.el7.x86_64
bzip2-1.0.6-13.el7.x86_64
perl-Compress-Raw-Bzip2-2.061-3.el7.x86_64
libzip5-1.6.1-1.el7.x86_64
bzip2-libs-1.0.6-13.el7.x86_64
zip-3.0-11.el7.x86_64
p7zip-16.02-10.el7.x86_64

So I recommend you to check if the above (most likely libzip5) packages are installed on your system.

Pleasen note, I compiled PHP 7.4 using "PHP Version Switcher v2" and the following configuration settings were used:

Code: [Select]
./configure  --with-config-file-path=/usr/local/php --enable-cgi --with-config-file-scan-dir=/usr/local/php/php.d --with-zlib=/usr --enable-mbstring --with-zip --enable-bcmath --enable-pcntl --enable-ftp --enable-exif --enable-calendar --enable-sysvmsg --enable-sysvsem --enable-sysvshm --with-tidy --with-curl --with-iconv --with-gmp --with-pspell --enable-gd --with-jpeg --with-freetype --enable-gd-jis-conv --with-webp --with-zlib-dir=/usr --with-xpm --with-openssl --with-pdo-mysql=mysqlnd --with-gettext=/usr --with-bz2=/usr --with-mysqli --enable-soap --enable-phar --with-xsl --with-xmlrpc --with-kerberos --enable-posix --enable-sockets --with-external-pcre --with-libdir=lib64 --with-mysql-sock=/var/lib/mysql/mysql.sock --enable-intl --enable-litespeed PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/local/lib64/pkgconfig

So compare the compilation setting used by the PHP selector and PHP Version Switcher v2. Hope it will help you to investigate and solve the problem quickly.

My server works under `CentOS Linux release 7.9.2009`.

Offline
*****
Re: php 7.4 compile fails due to libzip
« Reply #2 on: May 03, 2021, 05:55:14 AM »