Author Topic: subdomain DNS failure: loading from master file failed: file not found  (Read 368 times)

0 Members and 1 Guest are viewing this topic.

I use CWP7 as the web panel of my VPS. I just tried to add a new account with a domain like but it seems something is wrong with its DNS records.

When I want to add the domain to CentOSFreeDNSManager I face this error:
zone loading from master file /var/named/ failed: file not found
zone not loaded due to errors.

here are the records I added to the CeonOSFreeDNSManager.

However, the /var/named/ file exists.

Also, I checked the domain by this command:
named-checkzone /var/named/

and the result is:
zone loaded serial 2013071600

I already did this many times and the subdomain worked without any extra kinds of stuff.

Here is the zone records of the subdomain generated by the CWP7 automaticly:

Code: [Select]
    ; Generated by CWP
    ; Zone file for
    $TTL 14400      86400        IN      SOA (
    2013071600      ; serial, todays date+todays
    86400           ; refresh, seconds
    7200            ; retry, seconds
    3600000         ; expire, seconds
    86400 )         ; minimum, seconds 86400 IN NS 86400 IN NS IN A 152.***.***.*** IN A IN MX 0
    mail IN CNAME
    www IN CNAME
    ftp IN CNAME
    ; Add additional settings below this line
    _dmarc 14400 IN TXT "v=DMARC1; p=none"