Author Topic: Weird bad gateway error on WordPress.  (Read 240 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Weird bad gateway error on WordPress.
« on: April 06, 2021, 02:05:36 PM »
The site works fine but sometimes when I try to post a new post or reply to a comment the backend keeps loading until timeout and then the whole backend gives a bad gateway error but the site frontend homepage is working and it also gives a bad gateway error if you select a post, only the homepage keeps working.
I have to reboot the server for everything get back to normal and it happens every 3-4 inputs(posts or comments).
My specs:
2gb ram
3 cores cpu
Centos 7
Nginx and php-fpm 8.
The problem started to happen (I think) after switching from suphp and apache to php-fpm and nginx.

Offline
*****
Re: Weird bad gateway error on WordPress.
« Reply #1 on: April 07, 2021, 02:32:13 PM »
Hi, check the website error log at the problem moment. Maybe the website unable to save the post and you have the timeout error.
Also, 2GB RAM is too low in 2021 and you must not use ClamAV and many other things.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services