Author Topic: Error 500 Internal Server Error apache centos 6  (Read 6954 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Error 500 Internal Server Error apache centos 6
« on: June 23, 2015, 07:26:29 PM »
Hello everyone
I have a VPS with CentOS 6 and centos panel.
I have the following problem.
I have two domains targeted to the server
1.com 2.com
with the current configuration which is:

# vhost_start 1.com
<VirtualHost xx.xxx.xxx.xxx:80>
ServerName 1.com
ServerAlias www.1.com
ServerAdmin google@gmail.com
DocumentRoot "/home/1/public_html"
ScriptAlias /cgi-bin/ "/home/1/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/1/1.com/*.conf
 
<IfModule mod_suexec.c>
        SuexecUserGroup 1 1
</IfModule>
 
<IfModule mod_suphp.c>
        suPHP_UserGroup 1 1
        suPHP_ConfigPath /home/1
</IfModule>
 
<Directory "/home/1/public_html">
        AllowOverride All
</Directory>
 
</VirtualHost>
# vhost_end 1.com
 
# vhost_start 2.com
<VirtualHost xx.xxx.xxx.xxx:80>
ServerName 2.com
ServerAlias www.2.com
ServerAdmin google@gmail.com
DocumentRoot "/home/2/public_html"
ScriptAlias /cgi-bin/ "/home/2/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/2/2.com/*.conf
 
<IfModule mod_suexec.c>
        SuexecUserGroup 2 2
</IfModule>
 
<IfModule mod_suphp.c>
        suPHP_UserGroup 2 2
        suPHP_ConfigPath /home/2
</IfModule>
 
<Directory "/home/2/public_html">
        AllowOverride All
</Directory>
 
</VirtualHost>
# vhost_end 2.com

when trying to access from the browser, takes me to the site's default Apache (/ usr / local / apache / htdocs)
When change:

<VirtualHost xx.xxx.xxx.xxx:80>

by:

<VirtualHost *>

1.com works perfectly but jumps 2.com Error 500 Internal Server Error
and the log of apache says

[error] [client xxx.xxx.xxx] SoftException in Application.cpp:404: Mismatch between target UID (501) and UID (502) of file "/home/2/public_html/index.php

I tried to edit /usr/local/apache/conf/sharedip.conf
its current configuration is:

NameVirtualHost xx.xxx.xxx:80
<VirtualHost xx.xxx.xxx:80>
    ServerName xx.xxx.xxx
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin google@gmail.com
    <IfModule mod_suphp.c>
        suPHP_UserGroup nobody nobody
    </IfModule>
</VirtualHost>
<Directory "/">
        AllowOverride All
        Allow from all
        Order Deny,Allow
</Directory>

changing "ServerName xx.xxx.xxx" to "*" and entering the site from 2.com xxx.xxx.xxx/~2 works but not, leads to the folder by default.

So far I have not known how to make it work properly. Any ideas?
Thanks.