Author Topic: Pecl Ext not working after upgrading to 7.4  (Read 213 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Pecl Ext not working after upgrading to 7.4
« on: May 02, 2021, 06:50:05 PM »
Hi all
I have been using oauth 1 pecl extension with php 7.2
But after upgrading to 7.4 , I got Class 'OAuth' not found
I can not run my  script via cli
/opt/alt/php-fpm71/usr/bin/php index.php
I got same error.
How can I run a php file via cli with its settings



Offline
*****
Re: Pecl Ext not working after upgrading to 7.4
« Reply #1 on: May 03, 2021, 05:54:04 AM »
is oauth installed for php 7.4 ?

Offline
*
Re: Pecl Ext not working after upgrading to 7.4
« Reply #2 on: May 06, 2021, 09:21:15 AM »
Pecl extension oauth1  is not working with php7.4
So I tried https://github.com/thephpleague/oauth1-client  and it worked for me
Thanks