Author Topic: FYI - CWP 0.9.8.1061 & Rocky Linux  (Read 642 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
FYI - CWP 0.9.8.1061 & Rocky Linux
« on: May 13, 2021, 04:42:18 PM »
Just a quick FYI. Not sure if anyone cares or not.

We (Starburst, NOT CWP) installed CWP 0.9.8.1061 on Rocky Linux RC1 yesterday on a test box.

Everything went well and worked. Well, Apache Rebuild still isn't working. (But that's on CentOS also :/)

We also where able to update the Kernel, MariaDB and Dovecot from their respective CentOS 8 repos.

Rocky Linux is also working on an upgrade like RedHat did from CentOS to CentOS Stream.
So you can switch from CentOS 8/CentOS Stream to Rocky Linux.
Which also hopefully means in the future the version will be upgradable, since this is how Debian does their upgrades,
« Last Edit: May 13, 2021, 04:43:50 PM by Starburst »

Offline
*****
Re: FYI - CWP 0.9.8.1061 & Rocky Linux
« Reply #1 on: May 18, 2021, 05:00:30 AM »
Hi, Starburst.
Sounds good!
What error do you have with Apache rebuild?
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
**
Re: FYI - CWP 0.9.8.1061 & Rocky Linux
« Reply #2 on: May 18, 2021, 08:14:26 PM »
Hi, Starburst.
Sounds good!
What error do you have with Apache rebuild?

Clicked on WebServer Settings -> Apache Re-Build

And select Apache 2.4.46 & suPHP 0.7.2

But it stays at the default 2.4.39 even thought it says it completed.

That functionality seems hit & miss. More miss even on CentOS 8.

Offline
**
Re: FYI - CWP 0.9.8.1061 & Rocky Linux
« Reply #3 on: May 19, 2021, 09:27:24 PM »
Upgraded:
  libselinux-2.9-4.el8_3.x86_64           libselinux-utils-2.9-4.el8_3.x86_64
  python3-libselinux-2.9-4.el8_3.x86_64

Installed:
  apr-devel-1.6.2-1.x86_64              apr-util-devel-1.6.0-1.x86_64
  expat-devel-2.2.5-4.el8.x86_64        keyutils-libs-devel-1.5.10-6.el8.x86_64
  krb5-devel-1.18.2-5.el8.x86_64        libcom_err-devel-1.45.6-1.el8.x86_64
  libkadm5-1.18.2-5.el8.x86_64          libselinux-devel-2.9-4.el8_3.x86_64
  libsepol-devel-2.9-1.el8.x86_64       libverto-devel-0.3.0-5.el8.x86_64
  openssl-devel-1:1.1.1g-15.el8.x86_64  pcre2-devel-10.32-2.el8.x86_64
  pcre2-utf16-10.32-2.el8.x86_64        pcre2-utf32-10.32-2.el8.x86_64
  zlib-devel-1.2.11-16.2.el8.x86_64

Complete!
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
configure:
configure: Configuring Apache Portable Runtime library...
configure:
checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
  setting CFLAGS to "  -pthread"
  setting CPPFLAGS to " -DLINUX -D_REENTRANT -D_GNU_SOURCE"
  setting LDFLAGS to " "
configure:
configure: Configuring Apache Portable Runtime Utility library...
configure:
checking for APR-util... yes
checking for gcc... gcc
checking whether the C compiler works... no
Apache Rebuild Completed


Notification added

--

From /usr/local/apache/logs/erro_log

[Wed May 19 17:20:52.836744 2021] [mpm_event:notice] [pid 30989:tid 139976648229440] AH00492: caught SIGWINCH, shutting down gracefully
[Wed May 19 17:20:52.912960 2021] [mpm_event:notice] [pid 36673:tid 140268500484672] AH00489: Apache/2.4.39 (Unix) configured -- resuming normal operations
[Wed May 19 17:20:52.913172 2021] [core:notice] [pid 36673:tid 140268500484672] AH00094: Command line: '/usr/local/apache/bin/httpd'


But still didn't upgrade to 2.4.46

Offline
*
Re: FYI - CWP 0.9.8.1061 & Rocky Linux
« Reply #4 on: May 19, 2021, 09:36:36 PM »
looks like you have some issue with the compiler...try to check that as it has probably something missing
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
**
Re: FYI - CWP 0.9.8.1061 & Rocky Linux
« Reply #5 on: May 19, 2021, 09:41:05 PM »
looks like you have some issue with the compiler...try to check that as it has probably something missing

Will do.
It is a Release Candidate after all. And not for production use.