Author Topic: Firewall is blocking email delivery  (Read 730 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Firewall is blocking email delivery
« on: June 01, 2023, 08:04:33 PM »
I'm trying to put in place smtp setting for a shop and all seams ok if i disable the firewall . If firewall is active the the mail is put in que and never leave.
if i click detail from mail que i get
Code: [Select]
(connect to alt2.gmail-smtp-in.l.google.com[142.251.9.26]:25: Connection refused)\n
Seams theat google refuse my connection but is not true . If i will disable firewall my email will go with no problem.
In firewall config i have activated SMTP_BLOCK = "1"
and SMTP_ALLOWUSER ="user"
what i'm missing ?

Offline
****
Re: Firewall is blocking email delivery
« Reply #1 on: June 02, 2023, 02:06:48 AM »
Are you allowing outgoing mail ports in /etc/csf/csf.conf?
TCP_IN = "21,22,25,53,80,110,143,443,465,587,993,995,2083,2096,2304"
TCP_OUT = "20,21,22,25,22,53,80,110,113,443,2083,2096,587,993,995,2080,2443"
Code: [Select]
SMTP_PORTS = "25,465,587"
PORTS_imapd = "143,993"
PORTS_pop3d = "110,995"