Author Topic: Problem mails from server / postfix.  (Read 293 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Problem mails from server / postfix.
« on: June 05, 2021, 11:38:38 PM »
For a few days I have detected that my server does not send me emails from root (ssh access, firewall warning) ... after reviewing several things I find that, if I execute:
postconf -m
Mysql does not appear (in other servers that I have it does appear, I see this after executing tail -n 30 / var / log / maillog and looking for info online).
So I install postfix-mysql and after restarting postfix, it works again but .... now I have a different version of postfix than in the other servers that I have.
If I run the cwp update script:
sh / usr / local / cwpsrv / htdocs / resources / scripts / update_cwp
I get this error:
Redirecting to / bin / systemctl restart cwpsrv.service
Redirecting to / bin / systemctl restart httpd.service
Redirecting to / bin / systemctl reload httpd.service
curl: (22) The requested URL returned error: 404 Not Found
error: skipping http://repo.centos-webpanel.com/repo/8/x86_64/postfix-3.4.14-1.el8.x86_64.rpm - transfer failed
Redirecting to / bin / systemctl reload httpd.service

On the other servers, of course, I don't have that error.

If I run yum remove postfix-mysql on the other servers it tells me that it is not installed, but in this one if I uninstall it, after that, I have the mail problems again.

It is as if it had been installed through a different channel than the others (channel other than cwp).

All my servers are the same, same characteristics, same centos version, they are identical in everything, and I have not done anything about it.

Thanks in advance.

Offline
*
Re: Problem mails from server / postfix.
« Reply #1 on: June 11, 2021, 09:21:25 AM »
Same problem here since yesterday

postfix-mysql is missing

and

curl: (22) The requested URL returned error: 404 Not Found
error: skipping http://repo.centos-webpanel.com/repo/8/x86_64/postfix-3.4.14-1.el8.x86_64.rpm - transfer failed

I can access my mails but I can't send or receive any

I haven't try to install manually postfix-mysql as you did

Offline
*
Re: Problem mails from server / postfix.
« Reply #2 on: June 11, 2021, 06:11:01 PM »
having at this moment 3 servers and only passing in 1, after searching and looking, I saw where the problem was.
On the server that I had this problem, the repos were different, there were more ... now I don't remember, but when I installed postfix-mysql I saw that it was calling a repo that now I don't remember the name (then I can access and see).
Curious because the 3 are installed, in principle, from the same image, image that my hosting provides me.
What I did was clone the repos of the servers that did not have this problem on the server with the problem.
At that time I installed postfix (I had uninstalled it) and postfix-mysql installed it automatically, and I noticed that the versions of postfix were the same in all of them, which was not the case at the time of having the problem, the version of postfix on the server with the problem it was superior to the others.

The solution of installing postfix-mysql solves the mail problem but not the anacron update problem.