Author Topic: no DKIM record for any Domain [SOLVED]  (Read 2183 times)

0 Members and 1 Guest are viewing this topic.

no DKIM record for any Domain [SOLVED]
« on: April 29, 2022, 01:27:01 AM »
I install on ubuntu server 22.04  for use as temporary container server.

Create a centos instance using  centos/8-Stream image

Install CWP with no error  :)

Then create domains, email account and sync any email address with impasync (no more googleapps for free), then export container for move to real operational server.

On Datacenter, import the exported copy of container (more than 100 gb! and 3 hours) and reconfigure hostnames, setting real public ip and almost are ok. Hostname, PTR, etc are ok

Make a test sending mail to and obtain 9/10 - Fine ! .... but ...
But the problem discover was that CWP dont create DKIM entry for any domain. THIS is a point discont from a perfect 10/10

On Dkim Manager, try force create DKIM for one or all domain. Web Interface say "Sucess!" but nothing occured

On other container with Centos7, all works perfect!

Any body have a idea what can be happen.

THANK SO MUCH IN ADVANCE and sorry by my poor english


« Last Edit: April 29, 2022, 01:55:55 AM by luisl »

Re: no DKIM record for any Domain
« Reply #1 on: April 29, 2022, 01:55:10 AM »
I search a little and found that the "opendkim-tools" was not installed I run dnf install opendkim-tools to install it then rebuild the mail server and generate again the dkim for all domains and its WORKING  ;D

Re: no DKIM record for any Domain [SOLVED]
« Reply #2 on: April 29, 2022, 05:01:15 AM »
I think this is a false positive thing that opendkim-tools solves the problem. I don't have this installed.

What you needed to do was enable DKIM in the email configuration and rebuild. Then if the DKIM records are in not present in the DNS records, then you just rebuild the DNS record or all of them with:
Code: [Select]
/usr/local/cwp/php71/bin/php /scripts/cwp_api account rebuild_var_named_all
it's like drinking apple juice for being dehydrated. You didn't need the apple part, you needed the water.. It wasn't the apple part that solved your problem.
« Last Edit: April 29, 2022, 05:03:53 AM by iraqiboy90 »

Re: no DKIM record for any Domain [SOLVED]
« Reply #3 on: April 29, 2022, 05:58:53 PM »
hi  iraqiboy90!

i dont understand why the procedure what you say really don't work (try many times)

I see that command line opendkim-keygen can't find on system.

Next I post on forum, continue reading and find this solution and REALLY solved the problem.

I Think that Install Script de CWP for Centos 8 IS THE SOURCE of problem.

Thanks again !