Author Topic: After changing user package, user can not login  (Read 2293 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
After changing user package, user can not login
« on: August 02, 2021, 06:51:21 AM »
Hi Support Team,

After changing user package, that user can not login. I have another user where the package didn't change and he is able to login.
Please advise as user is not able to login on https (port 2083) or http port 2082.

I have the CWP7pro version.
I restarted the server  several times.
I rebuild-ed the Apache server
I also "changed the hostneme" (just saved it so it will regenerate the ssl certificate)
I cleared the cookies on the browser and also the whole browser history.
I closed the browser and rebooted the client machine.
I also applied all updates.

I'm able to connect on the web panel with root on port 2087 and I can go to users list and click on the configuration icon for the user with changed package and it will go to the host.domain.com:2083 and it won't pass the credentials.
If I enter credentials it will show me the logon is successful and then it will show again the logon screen.

It is very frustrating as I was extensively searching for a resolution and there is none so far. Years and hundreds of tickets were open and there is no response to this issue.

It seems that this issue is related to the rebuilding of the redirecting link with users credentials associated with the user configuration link from User accounts -> List Accounts
Can someone  please look at this issue as it is very clear where the problem resides.


Please advise.

Stelian

Offline
*
Re: After changing user package, user can not login
« Reply #1 on: December 19, 2021, 06:10:30 PM »
I had the same issue for a long time and could not figure it out. The solution that worked for me was to change the package of the affected users to something else and then change it back again.

Offline
*
Re: After changing user package, user can not login
« Reply #2 on: February 11, 2022, 11:51:10 PM »
Did you ever get to the bottom of this?

Just installed CWP Pro on a new server and I can't use the User login at all.

It just 302's back to the login page after showing "successful login"

Offline
**
Re: After changing user package, user can not login
« Reply #3 on: February 12, 2022, 07:45:52 AM »
Did you ever get to the bottom of this?

Just installed CWP Pro on a new server and I can't use the User login at all.

It just 302's back to the login page after showing "successful login"
try this
Code: [Select]
echo '{"compress_js":false,"compress_html":false}' > /usr/local/cwp/.conf/.devtools_configor
apply user language on the user again
User Account - Features,Themes,Languages - Language - Select language and "Force all"
« Last Edit: February 12, 2022, 07:47:35 AM by iraqiboy90 »

Offline
*
Re: After changing user package, user can not login
« Reply #4 on: February 12, 2022, 11:40:43 AM »
Thanks, tried both of those methods and still getting the redirects back to login page.


Offline
*
Re: After changing user package, user can not login
« Reply #5 on: February 12, 2022, 01:02:52 PM »
For the record, I can't login to any user accounts. There's only 1 account on there at the moment but I've tried creating another account and that wont login either.

Considering re-installing CWP from scratch at this point. I have CWP Pro on there for what it's worth.

Offline
**
Re: After changing user package, user can not login
« Reply #6 on: February 14, 2022, 10:25:55 PM »
Try this:
Features,Themes,Languages -> Themes -> Click and select the only theme there is -> Click Save Theme Default.

Check if you can login to user.

OR

Try assigning the package again to the user and see if that helps.