Author Topic: Issues with connection on CWP servers  (Read 903 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Issues with connection on CWP servers
« on: September 21, 2021, 02:56:10 AM »
Hello there,

It seems for the past few days I've been getting an error when trying to run the installer script.

Code: [Select]
[Recv failure: Connection reset by peer]
Does anyone know what's going on?  I read that it had nothing to do with me or my server.

Code: [Select]
Transaction Summary
================================================================================
Install  111 Packages

Total download size: 17 M
Installed size: 57 M
Downloading Packages:
[MIRROR] apr-1.6.2-1.x86_64.rpm: Curl error (56): Failure when receiving data from the peer for http://repo.centos-webpanel.com/repo/8/x86_64/apr-1.6.2-1.x86_64.rpm [Recv failure: Connection reset by peer]
[MIRROR] cwp-httpd-2.4.39-3.x86_64.rpm: Curl error (56): Failure when receiving data from the peer for http://repo.centos-webpanel.com/repo/8/x86_64/cwp-httpd-2.4.39-3.x86_64.rpm [Recv failure: Connection reset by peer]
[MIRROR] apr-util-1.6.0-1.x86_64.rpm: Curl error (56): Failure when receiving data from the peer for http://repo.centos-webpanel.com/repo/8/x86_64/apr-util-1.6.0-1.x86_64.rpm [Recv failure: Connection reset by peer]
[MIRROR] apr-1.6.2-1.x86_64.rpm: Curl error (56): Failure when receiving data from the peer for http://repo.centos-webpanel.com/repo/8/x86_64/apr-1.6.2-1.x86_64.rpm [Recv failure: Connection reset by peer]
[FAILED] apr-1.6.2-1.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success

Offline
***
Re: Issues with connection on CWP servers
« Reply #1 on: September 22, 2021, 06:24:27 PM »
I'm guessing you are running CentOS Stream using the CWP repos.

The CWP repos have had problems in the past.

If you are using Stream, you can switch back to the stream beta repos, or redo the server.
I would recommend AlmaLinux, since they also are the same company who does CloudLinux.

Offline
*
Re: Issues with connection on CWP servers
« Reply #2 on: September 22, 2021, 09:24:36 PM »
I've tried running the script in CentOS 8 (non-stream), Rocky Linux and CentOS Stream, all of them say the same thing.

Code: [Select]
http://repo.centos-webpanel.com/repo/8/x86_64/apr-1.6.2-1.x86_64.rpm [Recv failure: Connection reset by peer]

Which looks like a problem with http://repo.centos-webpanel.com, I've tried to figure this out and the only thing I've seen is that there is either an issue with the SSL credentials on the server-side or that the server can't handle the amount of traffic.


Offline
***
Re: Issues with connection on CWP servers
« Reply #3 on: September 22, 2021, 09:29:42 PM »
Is this error on a new install or update?

Again, I know CWP has had problems with their repos in the past.
But usually it's after you switch to them for updates.

Offline
*
Re: Issues with connection on CWP servers
« Reply #4 on: September 23, 2021, 03:34:31 AM »
Completely new install.  Minimal, no GUI, nothing done except and update.

Offline
*
Re: Issues with connection on CWP servers
« Reply #5 on: September 23, 2021, 06:57:33 AM »
try manually to see where is the issue

Code: [Select]
wget http://repo.centos-webpanel.com/repo/8/x86_64/apr-1.6.2-1.x86_64.rpm
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Issues with connection on CWP servers
« Reply #6 on: September 23, 2021, 09:58:18 PM »
When I use wget In the CentOS 8.4 VM, this is what happens:

Code: [Select]
apr-1.5.2-2.x86_64.rpm          19%[+++++++++++++++++========>                       ]  41.23K  --.-KB/s    in 0.07s
2021-09-23 17:50:12 (195 KB/s) - Read error at byte 14092/5777628 (Connection reset by peer). Retrying.

Weirdly, and just to see the difference, when I am using Fedora on my local machine (not the VM/server), it downloads without any issues.

So that's weird.  Why would it work on my local machine, but not in the VM?  Is my VM being blocked or something?

Offline
*
Re: Issues with connection on CWP servers
« Reply #7 on: September 24, 2021, 12:41:12 AM »
OK, I figured it out. 

I must have somehow been blocked by the centos-webpanel server for some reason.  I just blew away all three of my VMs, and reinstalled CentOS 8.4 (non-stream), and used a different domain name during the install process, and everything worked.

I'm not sure how this fixed the problem, other than maybe I was blocked, but maybe if it happens to someone else, they will know how to fix it.

Thank you everyone for the help, even though it didn't fix the problem, it gave me enough clues to figure it out.

Offline
*
Re: Issues with connection on CWP servers
« Reply #8 on: September 24, 2021, 02:56:44 AM »
Alright, just to be thorough, I tried installing the script on Rocky Linux, (which is the droplet I'm using on Digital Ocean).

I'm using VirtualBox with an install of Rocky Linux, as I like to test everything locally before I do anything on a live server.

I changed line 70 of the cwp-el8-latest script from this:
Code: [Select]
centosversion=`rpm -qa \*-release | grep -Ei "oracle|redhat|centos|cloudlinux" | cut -d"-" -f3|sed 's/\..$//'`


to this:
Code: [Select]
centosversion=`rpm -qa \*-release | grep -Ei "oracle|redhat|centos|cloudlinux|rocky" | cut -d"-" -f3|sed 's/\..$//'`


What I did differently was switch the VM's NAT network connection to a Bridged network connection and the installation failed for the exact same reason.

I tried it all again, leaving the VM's network connection as a NAT connection and everything worked.

So I'm not sure why that problem exists, or if it's supposed to be like that, but that's where the problem was.

If anyone wants to report this bug, and mark this thread as fixed or resolved, I'm cool with that.
« Last Edit: September 24, 2021, 02:59:15 AM by hunkah »