Author Topic: Failed to restart dovecot.service: Unit not found.  (Read 601 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Failed to restart dovecot.service: Unit not found.
« on: October 05, 2021, 05:05:58 PM »
Greetings,

I have used another panel in the past, but since the latest update went wrong I switched  to cwp and I have to say I like it a lot so far.

However, here is an issue:

After setting up a new server I noticed that Roundcube didn't work (connection to storage issue) so I tried to rebuild the mailserver and got the following error:

Quote
Failed to restart dovecot.service: Unit not found.

It's a fresh install on CentOS7 minimal - did anyone run into the same issue or has a suggestion on how to fix this problem? Any help would be greatly appreciated as I am not a PRO, but normally find my way around :)

To me it seems like dovecot was not installed for some reason. Is there a way for a new user to cwp to get this fixed?

Thanks so much!

Offline
*
Re: Failed to restart dovecot.service: Unit not found.
« Reply #1 on: October 05, 2021, 07:03:37 PM »
if you haven't tried it yet :

1. configure own nameservers (if any)
2. you set the hostname correctly (the ssl certificate is also generated automatically)
3. then from cwp panel -> Email-> MailServer Manager -> (here you choose what services you want to install - ClamAV, Amavis & Spamassassin and Installs DKIM & SPF, enables DKIM for New Accounts and Domains and Installs Policyd, enables hourly email limit per domain.)
4. click the (Rebuild Mail Server) button

Offline
*
Re: Failed to restart dovecot.service: Unit not found.
« Reply #2 on: October 05, 2021, 07:33:35 PM »
Greetings,

Thanks for your reply. I have tried this and still get the:

Failed to restart dovecot.service: Unit not found.

To me it seems like dovecot was not installed during the setup for some reason. I also tried to install it via yum (dovecot-mysql) but this resulted in another error so I uninstalled it again.

Maybe there is a simply trick to get dovecot integrated into CWP without messing anything else up?

Thanks again for your reply. It's greatly appreciated.
« Last Edit: October 05, 2021, 07:37:38 PM by KMger »

Offline
*
Re: Failed to restart dovecot.service: Unit not found.
« Reply #3 on: October 05, 2021, 08:50:07 PM »
Code: [Select]
yum -y install apr apr-util postfix dovecot dovecot-mysql dovecot-pigeonhole cyrus-sasl-devel cyrus-sasl-sql subversion bind bind-utils bind-libs file
and then rebuild mail server from cwp...but the question is, if something else is also missing on your server
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Failed to restart dovecot.service: Unit not found.
« Reply #4 on: October 05, 2021, 08:55:51 PM »
Thanks for your reply. I am going to give this a try now. Interestingly everything else seems to work just fine. I tested pretty much everything and this was the only issue discovered so far. My main problem was that I had to switch controlpanels in a hurry so I found this one and I am pretty amazed.

I'll update this post after giving your solution a try.

Thank you so much.

Update: After running this and restarting, cwp did not come back and could not be restarted. This is not your fault as it seems like something else must be wrong. I'll go ahead and order the installation service to make sure everything is setup correctly.
« Last Edit: October 05, 2021, 09:26:11 PM by KMger »