Author Topic: Apache start Error after selecting Nginx/Apache WS, fresh Rocky Linux Install  (Read 247 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
After setting the web server to Nginx/apache on multiple fresh Rocky Linux installs (v8.4 kernel 4.18.0-305.25.1.el8_4.x86_64), apache fails to start because mod_rpaf.so in not in /usr/local/apache/modules/ and I have to comment the contents of /usr/local/apache/conf.d/rpaf.conf

CWP version: 0.9.8.1099
Apache version: Apache/2.4.51
Web Servers: nginx-apache

Offline
*
After commenting the contents of rpaf.conf and starting apache, I set the the webserver back to apache, then enabled the apache_nginx webserver again and this time the mod_rpaf.so gets installed! This seems to be the quick fix for now. I can uncomment the contents of rpaf.conf and restart apache.

Here is part of the install log after re selecting the Nginx/apache

Nginx installation Done
...

/usr/lib64/apr/build-1/libtool --mode=install install mod_rpaf.la /usr/local/apache/modules/
libtool: install: install .libs/mod_rpaf.so /usr/local/apache/modules/mod_rpaf.so
libtool: install: install .libs/mod_rpaf.lai /usr/local/apache/modules/mod_rpaf.la
libtool: install: install .libs/mod_rpaf.a /usr/local/apache/modules/mod_rpaf.a
libtool: install: chmod 644 /usr/local/apache/modules/mod_rpaf.a
libtool: install: ranlib /usr/local/apache/modules/mod_rpaf.a
libtool: finish: PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbin" ldconfig -n /usr/local/apache/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/apache/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Offline
*
Another update: installing the "Development Tools" using the dnf package manager before selecting the nginx/apache as the webserver fixes this issue! to do that, execute:

dnf group install "Development Tools"