Author Topic: CWP7 - mail never gets delivered  (Read 117 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP7 - mail never gets delivered
« on: November 23, 2021, 06:17:39 PM »
My outgoing email stays in the que, never gets delivered. I know many people have the same problem.
BUT
Yesterday, on a freshly installed CWP7 configured a mail server. It worked perfectly, the mail-tester score was 10.0.
Then, I shut down the VPS. On a new VPS, reinstalled the same thing from scratch with new OS, exactly the same way.
Then, on the namecheap registrar, changed the ns1   and the ns2 records pointing to the new  IP address. Since then already a day has passed, but the new mail server is still not working.
In the que manager it shows "Queue reason:  (mail transport unavailable)"
Basically the settings, the CWP version on the two VPS servers are identical, except for the IP address.
How is it possible that mail was working on the first machine perfectly, and a day later on the new VPS doesn't?
I checked the new IP is not blacklisted.

How can I fix it?
Thanks
« Last Edit: November 23, 2021, 06:40:45 PM by ThomasT »

Offline
*
Re: CWP7 - mail never gets delivered
« Reply #1 on: November 23, 2021, 08:01:49 PM »
Just for curiosity's sake, started the old VPS (the name server IP addresses were  already removed from the namecheap regsitrar  a day ago, the domain names resolve to the new server).  I wanted to see what happens. Just could not believe my eyes: the old server, although should be dead, still is capable of delivering emails. It looks like my old mail server is cached somewhere in the internet.

Offline
*****
Re: CWP7 - mail never gets delivered
« Reply #2 on: November 24, 2021, 05:48:55 PM »
what is the error message in the mail queue ?