Author Topic: PHP Version Switcher v2 not changing version  (Read 5299 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Re: PHP Version Switcher v2 not changing version
« Reply #15 on: February 01, 2022, 09:45:29 PM »
am have 3 test servers VPS with centos stream 8.5 preinstalled Centos Stream 8 and use sandeep setup from step 2 step 3 step 4
 
https://www.mysterydata.com/convert-centos-8-to-centos-8-stream-install-cwp-control-panel-in-centos-8-stream/

PHP-FPM Selector works fine PHP Version Switcher v2 works  now olso after today automatic updated 

https://prnt.sc/26n0n2d
https://prnt.sc/26n0nif

I'm wondering why you have automatic updates enabled on php-fpm? Don't you have settings changed or secured in the php.ini files? These auto updates will reset php.ini every time.

Offline
*
Re: PHP Version Switcher v2 not changing version
« Reply #16 on: February 01, 2022, 10:05:34 PM »
I'm not complaining at all i have not started a topic about  it failing to update  ;) i just pointed out the last update does not allow you to update php versions also i dont need to supply logs for it either another member has already in one of the four topics thats open  ::)

Offline
*
Re: PHP Version Switcher v2 not changing version
« Reply #17 on: February 05, 2022, 11:12:17 PM »
If you get a sqlite3 error when switching from php 8.x to php 7.4 like undefined reference to 'sqlite3_ you can try and install a newer version of sqlite3:

Code: [Select]
cd /usr/local/src
wget https://www.sqlite.org/2022/sqlite-autoconf-3370200.tar.gz
tar xvfz sqlite-autoconf-3370200.tar.gz
cd sqlite-autoconf-3370200.tar.gz
CFLAGS="-DSQLITE_ENABLE_COLUMN_METADATA=1" ./configure
make & make install

« Last Edit: February 05, 2022, 11:14:16 PM by jijib »

Offline
****
Re: PHP Version Switcher v2 not changing version
« Reply #18 on: February 06, 2022, 01:46:45 AM »
am have 3 test servers VPS with centos stream 8.5 preinstalled Centos Stream 8 and use sandeep setup from step 2 step 3 step 4
 
https://www.mysterydata.com/convert-centos-8-to-centos-8-stream-install-cwp-control-panel-in-centos-8-stream/

PHP-FPM Selector works fine PHP Version Switcher v2 works  now olso after today automatic updated 

https://prnt.sc/26n0n2d
https://prnt.sc/26n0nif

I'm wondering why you have automatic updates enabled on php-fpm? Don't you have settings changed or secured in the php.ini files? These auto updates will reset php.ini every time.

Your second screenshot tells you everything you need to know.  You are forcing all domains to use FPM, thus there is no need for a default PHP.  If you turn off forced FPM, please respond back with any errors you receive while switching.
Google Hangouts:  rcschaff82@gmail.com