Author Topic: Cannot access CWP via public IP / domain in LAN  (Read 275 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Cannot access CWP via public IP / domain in LAN
« on: December 16, 2022, 05:48:07 AM »
Hi, we searched all the topics here & on Google but none fits our situation

We installed CWP on CentOS on a Proxmox VM (103) and followed this guide to open the necessary ports as follows
http://wiki.centos-webpanel.com/centos-mostly-used-ports




With the following settings on the physical NAT








With the above, our LAN users  cannot access public URLs :



https://PublicIP:2031 (CWP main panel)

https://domainname:2083 (CWP user panel)

https://myweb.site (User-created website)


It shows ERR_CONNECTION_TIMED_OUT



While internal URLs work fine

https://192.168.100.95:2083 (CWP panel)





However, users outside of the network are able to access public URLs


https://PublicIP:2031 (CWP main panel)

https://domainname:2083 (CWP user panel)

https://myweb.site (User-created website)






Now we can't figure out what else we are missing to check to allow LAN users to access our CWP via public IP or domain names

« Last Edit: December 16, 2022, 05:49:41 AM by Cyril »

Offline
***
Re: Cannot access CWP via public IP / domain in LAN
« Reply #1 on: December 17, 2022, 04:41:16 AM »
Cannot access CWP via public IP / domain in LAN
=====================
Cannot access CWP via public IP <--- check your firewall, routing and using public IP.IP.IP.IP
try it from device are outside your network....

domain in LAN <--- check your hosts....resolve conf (you can add manual )

Offline
**
Re: Cannot access CWP via public IP / domain in LAN
« Reply #2 on: January 08, 2023, 06:47:13 AM »
Does your router support loopback / NAT hairpin?