Author Topic: Roundcube version  (Read 583 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Roundcube version
« on: February 20, 2023, 12:23:52 AM »
What versions of roundcube are supported by cwp?  Index.php file says version 1.2.  Roundcube website lists 1.6 as the stable version.
Listen to everything Pixelpadre says.

Offline
*
Re: Roundcube version
« Reply #1 on: February 20, 2023, 09:40:10 AM »
What versions of roundcube are supported by cwp?  Index.php file says version 1.2.  Roundcube website lists 1.6 as the stable version.
Unfortunately version 1.5.3 is the last one working.
https://forum.centos-webpanel.com/index.php?topic=12064.msg43232#msg43232

Offline
**
Re: Roundcube version
« Reply #2 on: February 21, 2023, 01:48:18 PM »
my version is 1.4.11 according to the About tab on web based login to roundcube.  I tried to do the update as instructed on centoscwp wiki.   But it says I have the latest version already installed.
Listen to everything Pixelpadre says.

Offline
***
Re: Roundcube version
« Reply #3 on: March 04, 2023, 08:31:34 PM »
Please use Sandeep's newer directions rather than the older wiki information:
https://www.uxlinux.com/upgrade-to-roundcube-version-mail-on-cwp-centos-webpanel/

Offline
**
Re: Roundcube version
« Reply #4 on: March 07, 2023, 02:14:37 PM »
I TRIED THAT.  BUT GOT AN ERROR WHEN TRYING TO INSTALL INTL.  I TRIED SENDING HIM AN EMAIL BUT IT KEEPS BOUNCHING BACK.
« Last Edit: March 07, 2023, 02:24:31 PM by Namaste »
Listen to everything Pixelpadre says.

Offline
***
Re: Roundcube version
« Reply #5 on: March 07, 2023, 03:29:58 PM »
His instructions worked on 2x of my CWP servers, but I did get an error on one of them. I can't recall offhand how I resolved it, but can you post the error here to jog my memory?

Offline
*
Re: Roundcube version
« Reply #6 on: March 14, 2023, 03:57:40 PM »
ffwwawfw
At woocacasino, players from across the globe can experience all the thrills of casino gaming. With a vast selection available - including classic table games like Roulette https://wooca-casino.com/ and Blackjack, modernized Poker variations, dynamic slots titles and even live dealer tables for an immersive online gambling environment there's something to suit every player!

Offline
*
Re: Roundcube version
« Reply #7 on: March 15, 2023, 03:23:47 PM »
I am trying to update roundcube to 1.5 but I keep getting this error:

Code: [Select]
PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
when I try to run the update command. Has anyone run into this?

Offline
***
Re: Roundcube version
« Reply #8 on: March 16, 2023, 04:52:35 PM »
These commands are not working?

Quote
cd /usr/local/cwpsrv/var/services/
cp -R roundcube roundcube_old
wget https://github.com/roundcube/roundcubemail/releases/download/1.5.3/roundcubemail-1.5.3-complete.tar.gz
tar zxvf roundcubemail-1.5.3-complete.tar.gz
/usr/local/cwpsrv/var/services/roundcubemail-1.5.3/bin/installto.sh /usr/local/cwpsrv/var/services/roundcube

Offline
*
Re: Roundcube version
« Reply #9 on: March 17, 2023, 03:11:04 PM »
Correct, when I run the install command, I get this error:
Code: [Select]
PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0

Offline
***
Re: Roundcube version
« Reply #10 on: March 18, 2023, 02:45:59 AM »
IonCube should work in PHP versions up to 7.4. Do you have it enabled in all your installed versions? If not, recompile with IonCube support.

Offline
**
Re: Roundcube version
« Reply #11 on: March 19, 2023, 01:45:50 PM »
These commands are not working?

Quote
cd /usr/local/cwpsrv/var/services/
cp -R roundcube roundcube_old
wget https://github.com/roundcube/roundcubemail/releases/download/1.5.3/roundcubemail-1.5.3-complete.tar.gz
tar zxvf roundcubemail-1.5.3-complete.tar.gz
/usr/local/cwpsrv/var/services/roundcubemail-1.5.3/bin/installto.sh /usr/local/cwpsrv/var/services/roundcube

omg.   bullten is back
Listen to everything Pixelpadre says.

Offline
*
Re: Roundcube version
« Reply #12 on: March 19, 2023, 11:31:05 PM »
IonCube should work in PHP versions up to 7.4. Do you have it enabled in all your installed versions? If not, recompile with IonCube support.

I just checked, I do have php-fpm enabled and versions 7.4, 8.0, 8.1, 8.2, and all with ioncube enabled. I even rebuilt them all just for good measure to no avail.

What is strange is that I can't even get a php -v command output? But the server is running perfectly, speedy even!

PHP.ini hierarchy appears to be the issue, where does root use php.ini?


Code: [Select]
[root@srv roundcubemail-1.5.3]# bin/installto.sh /usr/local/cwpsrv/var/services/roundcube
PHP Warning:  Missing arginfo for uploadprogress_get_info() in Unknown on line 0
PHP Warning:  Missing arginfo for uploadprogress_get_contents() in Unknown on line 0
PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
[root@srv roundcubemail-1.5.3]# php -v
PHP Warning:  Missing arginfo for uploadprogress_get_info() in Unknown on line 0
PHP Warning:  Missing arginfo for uploadprogress_get_contents() in Unknown on line 0
PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0



Offline
*
Re: Roundcube version
« Reply #13 on: March 20, 2023, 12:10:05 AM »
OK, I figured it out!

Apparently if php-fpm is enabled, you have to prefix the command with
Code: [Select]
/opt/alt/php-fpm74/usr/bin/php

example:
Code: [Select]
/opt/alt/php-fpm74/usr/bin/php bin/installto.sh /usr/local/cwpsrv/var/services/roundcube

Offline
**
Re: Roundcube version
« Reply #14 on: March 20, 2023, 01:18:52 AM »
His instructions worked on 2x of my CWP servers, but I did get an error on one of them. I can't recall offhand how I resolved it, but can you post the error here to jog my memory?

curl -s -L https://www.uxlinux.com/upload/tmp/cwp_rc_fix.sh | bash

upgrade roundcube tutorial throws ajax error during the intl
« Last Edit: March 20, 2023, 01:20:56 AM by Namaste »
Listen to everything Pixelpadre says.