Author Topic: PHP versiyon error  (Read 954 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP versiyon error
« on: March 04, 2023, 07:21:24 PM »
Hello,

CWP PRO
PHP version: 7.1.4 Forced PHP-FPM: 7.2
Web Servers: nginx-only
Distro Name: CentOS Linux release 7.9.2009 (Core)


roundcube 1.6.1 wants on php 7.3 version to run. I am installing 7.4.0 from PHP version selector. It shows 7.4.0 in Centos Web Panel. Php 7.4.0 appears when I type php -v command after SSH connection.

But I send a file to the server <?php phpinfo(); When I put ?> it shows 7.2.30 and roundcube doesn't accept it because php version is low.

How can I solve this problem?

Offline
****
Re: PHP versiyon error
« Reply #1 on: March 04, 2023, 08:29:41 PM »
Where are you installing Roundcube? Under a vhost running the version of PHP (7.4) that meets the requirements? Or are you trying to update the CWP version of Roundcube?

Offline
*
Re: PHP versiyon error
« Reply #2 on: March 04, 2023, 09:02:53 PM »
Where are you installing Roundcube? Under a vhost running the version of PHP (7.4) that meets the requirements? Or are you trying to update the CWP version of Roundcube?

/usr/local/cwpsrv/var/services/roundcube

It was already installed here. It had version 1.4. I updated to version 1.5. But now when I want to install 1.6.1, PHP 7.2.3 sees it and does not install it.

Offline
****
Re: PHP versiyon error
« Reply #3 on: March 04, 2023, 10:21:45 PM »
Anything under /usr/local/cwpsrv runs under CWP's custom, untouchable PHP 7.2 (labeled as PHP 7.1). You have to install elsewhere to have control over it.