Author Topic: Error 403 Forbidden (You don't have permission to access / on this server)  (Read 18929 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hello. I get error 403 (You do not have permission to access / on this server). I performed mod security uninstall and the page is active normally, but when active mod security happens the error 403. I am new to the CWP panel. Could you help me sort it out? There are several tips here in the forum but I confess that I did not find any yet to solve the problem. Thank you very much in advance.

Offline
*
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Error 403 Forbidden (You don't have permission to access / on this server)
« Reply #2 on: September 03, 2019, 05:39:28 PM »
search....
http://wiki.centos-webpanel.com/mod_security-for-cwp
Thanks for the info was of great help. Now when the site is only on the Centos test page. My site does not appear even jpa being in the server. What would it be?

Offline
*
CWP -> Mod Security -> Change to Comodo WAF
André Bastos
ISBrasil Hospedagem de Site

Offline
****
Change to Comodo WAF
Agreed, OWASP is too aggressive of a default.
But this tutorial has relevant info and suggested changes if you do decide to use OWASP rules.

Offline
*
I also have this issue when switch the web server from apache only to nginx only.
it only work apache only or Apache & nginx or Apache&nginx&varnish
tried: uninstall Mod_security, re-generate Vhost, Fix permissions from GUI.

logs.
Code: [Select]
[i][i][i]2023/08/14 18:39:45 [error] 4784#4784: *65 openat() "/home/weasam/nextcloud.domain.com/index.php/apps/files/preview-service-worker.js" failed (20: Not a directory), client: 192.168.10.1, server: nextcloud.domain.com, request: "GET /index.php/apps/files/preview-service-worker.js HTTP/1.1", host: "nextcloud.domain.com", referrer: "https://nextcloud.domain.com/index.php/apps/files/preview-service-worker.js"
2023/08/14 18:40:12 [error] 5206#5206: *70 openat() "/home/weasam/nextcloud.domain.com/index.php/apps/files/preview-service-worker.js" failed (20: Not a directory), client: 192.168.10.1, server: nextcloud.domain.com, request: "GET /index.php/apps/files/preview-service-worker.js HTTP/1.1", host: "nextcloud.domain.com", referrer: "https://nextcloud.domain.com/index.php/apps/files/preview-service-worker.js"
2023/08/14 18:40:21 [error] 5330#5330: *71 openat() "/home/weasam/nextcloud.domain.com/index.php/apps/files/preview-service-worker.js" failed (20: Not a directory), client: 192.168.10.1, server: nextcloud.domain.com, request: "GET /index.php/apps/files/preview-service-worker.js HTTP/1.1", host: "nextcloud.domain.com", referrer: "https://nextcloud.domain.com/index.php/apps/files/preview-service-worker.js"
2023/08/14 18:40:34 [error] 5551#5551: *73 openat() "/home/weasam/nextcloud.domain.com/index.php/apps/files/preview-service-worker.js" failed (20: Not a directory), client: 192.168.10.1, server: nextcloud.domain.com, request: "GET /index.php/apps/files/preview-service-worker.js HTTP/1.1", host: "nextcloud.domain.com", referrer: "https://nextcloud.domain.com/index.php/apps/files/preview-service-worker.js"
2023/08/14 18:40:42 [error] 5663#5663: *74 openat() "/home/weasam/nextcloud.domain.com/index.php/apps/files/preview-service-worker.js" failed (20: Not a directory), client: 192.168.10.1, server: nextcloud.domain.com, request: "GET /index.php/apps/files/preview-service-worker.js HTTP/1.1", host: "nextcloud.domain.com", referrer: "https://nextcloud.domain.com/index.php/apps/files/preview-service-worker.js"[/i][/i][/i]

From the log it says is missing file /apps/files/preview-service-worker.js. when I go to file manager , it's confirmed missing this file.
but why would it work when switchted to apache webserver. I will regenerate this issue from new Nextcloud installation