Author Topic: Job for named.service failed because the control process exited with error code.  (Read 1318 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Servidor DNS no funciona y presenta este mensaje en el Status! Ayuda por favor!
!======================================================!

named.service - Berkeley Internet Name Domain (DNS)
   Loaded: loaded (/usr/lib/systemd/system/named.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2023-07-24 16:50:04 EDT; 1min 23s ago
  Process: 20752 ExecStartPre=/bin/bash -c if [ ! "$DISABLE_ZONE_CHECKING" == "yes" ]; then /usr/sbin/named-checkconf -z "$NAMEDCONF"; else echo "Checking of zone files is disabled"; fi (code=exited, status=1/FAILURE)

Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: zone ns10866.dizinc.com/IN: loaded serial 2013071600
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: zone esemorenoyclavijo.gov.co/IN: loaded serial 2023071873
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: dns_rdata_fromtext: /var/named/vps.esemorenoyclavijo.gov.co.db:4: near 'ns1.centos-webpanel.com..': empty label
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: zone vps.esemorenoyclavijo.gov.co/IN: loading from master file /var/named/vps.esemorenoyclavijo.gov.co.db failed: empty label
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: zone vps.esemorenoyclavijo.gov.co/IN: not loaded due to errors.
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co bash[20752]: _default/vps.esemorenoyclavijo.gov.co/IN: empty label
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co systemd[1]: named.service: control process exited, code=exited status=1
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co systemd[1]: Unit named.service entered failed state.
Jul 24 16:50:04 vps.esemorenoyclavijo.gov.co systemd[1]: named.service failed.

Offline
****
Seems pretty self-explanatory. Look hard at:
/var/named/vps.esemorenoyclavijo.gov.co.db
There is something corrupt in it (bad syntax?) near  the beginning of the file -- first few lines.