Author Topic: Issues With Nginx  (Read 596 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Issues With Nginx
« on: November 29, 2023, 12:11:00 PM »
New CWP User here,  I'm using CWP Pro.

Only Apache:
* Auto SSL Works
* accessing the site over http and https works

Only Nginx:
* Auto SSL doesn't works. (It says "DNS of your domain doesn't point to this server or you have htaccess restrictions")
* accessing the site over http gives ERR_EMPTY_RESPONSE
* accessing the site over https causes browser error. When proceed, it shows test page instead of expected.
* Ne erros on var/messages/logs, service is running fine.


I have tried rebuilding several times. Also logging with root doesn't fixes it.
« Last Edit: November 29, 2023, 12:14:46 PM by kingOf0 »

Offline
*
Re: Issues With Nginx
« Reply #1 on: November 29, 2023, 05:45:52 PM »
Fresh installation of cwp pro fixed it. I was upgraded to cwp pro I think which caused problem.

Offline
****
Re: Issues With Nginx
« Reply #2 on: December 01, 2023, 02:26:18 AM »
Glad you got it sorted. You need a properly licensed CWP Pro (activated) in order to run Nginx (as I do).