Author Topic: ldd (GNU libc) 2.17 on CentOS 7.9.2009 Doesn't support recent Version of Nodejs  (Read 412 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
My current Node js app Require Version after 18.19.0 (Hydrogen)
And The versions are currently available on CWP-Centos7 are
19.9.0 and 21.4.0
But these need ldd 2.27.

Code: [Select]
Running node v21.3.0 (npm v)
node: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by node)
node: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by node)
node: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by node)
node: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by node)
node: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by node)
node: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by node)
node: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by node)


If i want to upgrade the ldd version

Code: [Select]
sudo yum update glibcIs there will be will be any error? Has anyone done this before?


Note: This is a risky operation, and it's recommended to perform it on a test system first. Do not attempt this on a production system unless you are fully aware of the consequences.