Author Topic: PHP Version Switcher / PHP Selector not updating PHO  (Read 799 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP Version Switcher / PHP Selector not updating PHO
« on: February 23, 2024, 05:35:53 PM »
I have 2 servers, BOTH have the same issue.

Apache version: Apache/2.4.57
PHP version: 7.4.33
MySQL version: 10.4.33-MariaDB

They are 4 core, 8gb ram (VPS in on KVM)

Distro Name: CentOS Linux release 7.9.2009 (Core)
Kernel Version: 3.10.0-1160.108.1.el7.x86_64
Platform: x86_64 kvm

I am using Centos Web Panel Pro. Now to the issue

Tried updating PHP from 7.4.33 to 8.3.1 - Waited 15-20 minutes. Final message on the Screen/Log is "Build Complete"

Even tried rebooting the server but the build is still 7.4.33 :( What am I doing wrong?

I tried searching the forum and found a couple of people who said it might be a memory issue (they had less than 2gb ram.. But I have 8gb ram!)

Hope someone can help

Offline
*
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #1 on: February 23, 2024, 05:46:33 PM »
Using the PHP version switcher, the last message on the build is;

Code: [Select]
"Build complete.

Don't forget to run 'make test'.

Installing shared extensions: /usr/local/lib/php/extensions/no-debug-non-zts-20190902/"

If I used PHP Selector, this is what I got:

Code: [Select]
"Build complete.
Don't forget to run 'make test'.

Installing shared extensions: /opt/alt/php83/usr/lib/php/extensions/no-debug-non-zts-20230831/
Creating config file

Build Completed
###################"

But How do I select it? Centos still says my PHP is 7.4.33 (this is on BOTH my VPS/servers)

Offline
*
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #2 on: February 24, 2024, 12:22:39 AM »
Ok, this is wierd

I tried to Upgrade it to 8.2.14 and it worked!!!

Then I from there, I tried to upgrade to 8.3 and 8.3.1 but same issue, not working :(

Offline
****
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #3 on: February 24, 2024, 02:40:39 AM »
There have been some issues with the 8.3.x tree. You could try to build without IonCube and mbstring support and see if that works. Or wait until the bugs have been shaken out better. 8.2.14 should meet your needs, unless you are a cutting edge developer ;)

Offline
*
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #4 on: February 24, 2024, 02:58:57 AM »
There have been some issues with the 8.3.x tree. You could try to build without IonCube and mbstring support and see if that works. Or wait until the bugs have been shaken out better. 8.2.14 should meet your needs, unless you are a cutting edge developer ;)

thanks! no, not a cutting edge developer.. far from it :)  just read somewhere that 8.3 is at least 20% faster for woocommerce/wordpress than 8.2 :) (which is supposed to be faster from 7.4..)

Offline
****
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #5 on: February 24, 2024, 01:09:11 PM »
I've posted this in other threads, but to get PHP 8.3.x working in CWP, you have to build it without the following options:

mbstring
imagick
ioncube

But without ionCube, some encrypted PHP scripts won't work.
Check their requirements, and if it says it need ionCube, you are stuck with PHP 8.2.x for right now.
And that has nothing to do with CWP, that is due to the ionCube Loaders not supporting PHP 8.3., yet (as of this post).

Offline
*
Re: PHP Version Switcher / PHP Selector not updating PHO
« Reply #6 on: February 24, 2024, 11:19:46 PM »
I've posted this in other threads, but to get PHP 8.3.x working in CWP, you have to build it without the following options:

mbstring
imagick
ioncube

But without ionCube, some encrypted PHP scripts won't work.
Check their requirements, and if it says it need ionCube, you are stuck with PHP 8.2.x for right now.
And that has nothing to do with CWP, that is due to the ionCube Loaders not supporting PHP 8.3., yet (as of this post).

thanks.. had to switch back to 7.4.33 from 8.2 because many of the Wordpress plugins not yet compatible with 8 :(

Did install 8.2 on another server to test suff