Author Topic: Postfix Won't Start  (Read 6506 times)

0 Members and 1 Guest are viewing this topic.

Postfix Won't Start
« on: January 04, 2016, 04:51:12 PM »
Or perhaps more accurately thinks it starts with an [ ok ] but dies right away. Maillot says:
Jan  4 11:30:53 localhost postfix/postfix-script[18726]: starting the Postfix mail system
Jan  4 11:30:53 localhost postfix/master[18727]: warning: could allocate space for only 100 open files
Jan  4 11:30:53 localhost postfix/master[18727]: warning: inet_addr_host: skipping address family 2: Too many open files
Jan  4 11:30:53 localhost postfix/master[18727]: fatal: /etc/postfix/ line 90: bad hostname or network address:

A little back story. My server is using waaaaay too much RAM, 13.5GB not including cache and I don't think I have that much on the server including the OS and backups! (DF -h says I've got about 5GB on the drives total :o ) So I restarted cwpsrv, httpd, and postfix to see if one of them was hoarding memory for some dumb reason, that's when postfix got uncooperative. I have CWP, Apache 2.2.27, PHP 5.5.30, mysql 5.1.73 on a Xeon quad core 2.6ghz with 24gb of RAM. I'm running 2 wordpress sites, a joomla site, and a static site. I'm am running varnish from memory but that's only reporting about 160MB right now. A ps aux doesn't show who's hogging the RAM, clamd is the biggest pig at only 1.2%.

I've tried rebuilding postfix which didn't help I still get the same error message. I've tried changing it to my server's IP, localhost, and my server's hostname, all still threw the same error. I searched the error message and tried creating a /var/spool/postfix/etc/ with a few necessary files that the Gentoo forums recommend and it didn't help so I undid that "fix".

A bug I think I've found is that if you select anti spam, rDNS, DKIM, in the rebuild, then try and rebuild postfix again without them later, it won't let you even if you've unchecked the boxes.

My server is about a 2hr drive away and I have to work this afternoon so I was going to try and restart it tomorrow morning just in case I have to pay it a visit. In the mean time if anyone has any suggestions I'd appreciate it greatly.

Re: Postfix Won't Start
« Reply #1 on: January 05, 2016, 03:03:23 AM »
Fixed! it was an issue with not enough open files allowed. Had to do the sysctl stuff here:

and also this:

Edit the /etc/pam.d/system-auth, and add this entry:
session required /lib/security/$ISA/

Still don't know what's eating up the RAM.
« Last Edit: January 05, 2016, 03:16:43 AM by Darkroom »