Author Topic: Need HTTP/2 support with Apache  (Read 18730 times)

0 Members and 2 Guests are viewing this topic.

Offline
*
Need HTTP/2 support with Apache
« on: February 19, 2016, 01:50:29 PM »
As you may or may have not heard, Chrome will drop support for SPDY SSL in May. So it's best practice to go ahead and upgrade your ssl protocol to HTTP/2, sadly the apache version (2.2.27) that comes with CWP doesn't support HTTP/2 I believe. Correct me if I'm wrong.

But we need the next version of CWP to support HTTP/2 SSL.
Unless you can provide documentation below of how we can go ahead and do it ourselves. :)

Thanks!
Trying to help people :)
Chords and Lyrics

Offline
*
Re: Need HTTP/2 support with Apache
« Reply #1 on: March 20, 2016, 11:51:18 AM »
Actually this is now easy task. First of all you have to upgrade your apache to version 2.4.17 or higher version to be able to run h2 module. This is major problem for old CMS :) Cpanel have a lot of issues with upgrades from 2.2 to 2.4 :) A lot easier is to run mod_spdy but it is potential security issue because use old ssl - if I remember correctly 1.0.1h also is not maintained a lot from apache foundation :)
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*
Re: Need HTTP/2 support with Apache
« Reply #2 on: May 04, 2016, 02:42:44 PM »


I'd like to see CWP make it easy and add the upgrade apache to 2.4.17 as an option in the Apache Compiler :)
Because I tried to upgrade it with the guide I found here (https://blog.bullten.com/upgrade-to-apache-2-4-x-and-suphp-0-7-2-in-centos-web-panel-cwp/)

And failed big time. Ran into the 500 error, and I did everything the guide said. So I'd rather play it safe and just ask the Admin to add it as an option, along with the http2 module as a checkbox when compiling
Trying to help people :)
Chords and Lyrics

Offline
*****
Re: Need HTTP/2 support with Apache
« Reply #3 on: May 04, 2016, 03:25:32 PM »
https://blog.bullten.com/upgrade-to-apache-2-4-x-and-suphp-0-7-2-in-centos-web-panel-cwp/

as a partner, this tutorial only works on previous versions of cwp. Bullten have a modified version of cwp and is available only if you purchase vps or dedi from them

Offline
*
Re: Need HTTP/2 support with Apache
« Reply #4 on: May 04, 2016, 06:08:17 PM »
That would explain it then lol

We need it in the stock build of CWP then  ;D
Trying to help people :)
Chords and Lyrics

Offline
*****
Re: Need HTTP/2 support with Apache
« Reply #5 on: May 05, 2016, 06:21:36 AM »
sooner or later Apache 2.4 will be the part of cwp

Offline
***
Re: Need HTTP/2 support with Apache
« Reply #6 on: June 20, 2016, 01:36:59 PM »
https://blog.bullten.com/upgrade-to-apache-2-4-x-and-suphp-0-7-2-in-centos-web-panel-cwp/

as a partner, this tutorial only works on previous versions of cwp. Bullten have a modified version of cwp and is available only if you purchase vps or dedi from them

Did you add the additional line to vhost file for each domain?
<Directory "/home/USER/public_html">
        AllowOverride All
   Require all granted
</Directory>

Offline
*
Re: Need HTTP/2 support with Apache
« Reply #7 on: November 26, 2016, 03:19:42 AM »
I did, even upgrade to Apache 2.4 seems fine in the beginning, it will:
1. broken display when select CWP's PHP info  (this will broken too if you just use PHP switcher to PHP7)
2. let's encrypt https stop working and the https sites broken.

Really hope CWP can officially support Apache 2.4, since the current 2.2 will lost support next year. Other critical packages like openssl 1.1.0 and suPHP0.72


Thanks a lot for your efforts.

Offline
*****
Re: Need HTTP/2 support with Apache
« Reply #8 on: November 26, 2016, 03:13:25 PM »
yes centos 7 is under development with apache 2.4