Author Topic: no more idle workers - high load  (Read 23381 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
no more idle workers - high load
« on: March 07, 2016, 12:45:10 PM »
Hello,

I have an image hosting site, when my apache idle worker is out, the server load will increase; see the screenshot here
so my question is -> how can i increase my idle worker number?

or any solution to serve direct image requests?
as i check my 70% httpd traffic is image serving.
if we can i want to use my memory more efficiently, because right now more than 8GB is free (i have 14GB total)

ps: yes, i already use CloudFlare as CDN/cache

Thanks
Bye
« Last Edit: March 07, 2016, 12:53:05 PM by szunyi »

Offline
*****
Re: no more idle workers - high load
« Reply #1 on: March 08, 2016, 01:01:55 PM »
increase the maxclient for the apache

Offline
*
Re: no more idle workers - high load
« Reply #2 on: March 08, 2016, 02:37:44 PM »
right now there isn't any entry about this in my apache config,
im using the default apache config with CWP

what is the default value if not definided?

increase the maxclient for the apache

Offline
*****
Re: no more idle workers - high load
« Reply #3 on: March 08, 2016, 07:27:17 PM »
right now there isn't any entry about this in my apache config,
im using the default apache config with CWP

what is the default value if not definided?

increase the maxclient for the apache
256 is the default
see this thread http://forum.centos-webpanel.com/apache/apache-maxclient-for-prefork-mpm/

you can try this config if you're using prefork mpm (which is default) :
Code: [Select]
# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    ServerLimit         512
    MaxClients          512
    MaxRequestsPerChild   0
</IfModule>
« Last Edit: March 08, 2016, 07:30:04 PM by Sandeep »

Offline
*
Re: no more idle workers - high load
« Reply #4 on: March 09, 2016, 05:55:35 AM »
you should also install nginx in front of apache to reduce the number of apache processes.
installation of nginx can be done under WebServers in CWP
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: no more idle workers - high load
« Reply #5 on: March 21, 2016, 01:02:37 PM »
im not brave enough to do this on this LIVE server, because if something collapse that is hurt for me heavily :'(

you should also install nginx in front of apache to reduce the number of apache processes.
installation of nginx can be done under WebServers in CWP

Offline
*****
Re: no more idle workers - high load
« Reply #6 on: March 21, 2016, 03:20:58 PM »
it will not collapse if you didn't change anything eg. ports

Offline
*
Re: no more idle workers - high load
« Reply #7 on: March 21, 2016, 03:23:59 PM »
with apache and php i dont change anything

it will not collapse if you didn't change anything eg. ports

Offline
*****
Re: no more idle workers - high load
« Reply #8 on: March 21, 2016, 03:38:51 PM »
you can safely enable nginx as reverse proxy from cwp

Offline
*
Re: no more idle workers - high load
« Reply #9 on: March 21, 2016, 03:43:07 PM »
okay, next day i will try it :) - after a full backup

you can safely enable nginx as reverse proxy from cwp
« Last Edit: March 21, 2016, 04:03:54 PM by szunyi »

Offline
*
Re: no more idle workers - high load
« Reply #10 on: March 22, 2016, 09:27:51 AM »
its done :)

but right now i dont have apache status page ->

Offline
*****
Re: no more idle workers - high load
« Reply #11 on: March 22, 2016, 10:52:46 AM »
Hello.

Probably something went wrong.
You can try contact with CWP support.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: no more idle workers - high load
« Reply #12 on: March 22, 2016, 10:56:14 AM »
right now as i check the nginx status page, there is useless for me:

This configuration creates a simple web page with basic status data which may look like as follows:

Active connections: 291
server accepts handled requests
 16630948 16630948 31070465
Reading: 6 Writing: 179 Waiting: 106

source

LOL :)


Hello.

Probably something went wrong.
You can try contact with CWP support.

Offline
*****
Re: no more idle workers - high load
« Reply #13 on: March 22, 2016, 11:54:04 AM »
its done :)

but right now i dont have apache status page ->


when nginx is active Apache runs on back end all requests are processed by nginx. Hence this is normal