Author Topic: How to upgrade libmysqlclient to higher than 5.1  (Read 10231 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
How to upgrade libmysqlclient to higher than 5.1
« on: April 09, 2016, 08:16:07 PM »
Hi,

I installed a classified (phpprobid) php script on my Centos 6.7 CWP server but the scripts run so slow that it is almost impossible to use it,

I also contacted the developer and the reply was to check with ISP as it is a server issue

I had the script running for years on Godaddy hosted server with no issues.

I ran a provided script to check compatibility and it gave the below result
================================================================
php 5.3.27                               <=>+5.4.45 Passed
mySQL 5.1+ (5.5 recommended) <=> mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $ Failed
Server Vars                              <=> Passed
open_basedir restriction              <=> Passed
PDO Library w/ MySQL Driver       <=> Enabled
mcrypt Extension                       <=> Enabled
GD Library                                <=> Enabled
ionCube Loaders 4.4+                 <=> Enabled
Important: ionCube Loaders v4.4+ are required. For more information on how to install them, please click here.
If they are run-time loaded, please disregard this message.
mod_rewrite extension               <=> Disabled / check failed
(optional) The mod_rewrite apache extension should be loaded in order for SEO urls to work.
There are alternatives to this extension if running ngnix or Microsoft IIS.
PHP Configuration Options           <=> post_max_size: 8M => Min.: 32MB => Failed
max_input_vars: 1000                <=> Min.: 1000 Passed  | memory_limit: 128M   Min.: 128MB Passed
(recommended) the above php configuration options should have the minimum values set as described.
cURL Library                             <=> Enabled
(optional) The cURL library is needed by the USPS and Australia Post shipping modules.
allow_url_fopen = on                 <=> Enabled
(optional) Required if you wish to allow remote images to be added to listings.
SOAPClient                               <=> Enabled
(optional) The SOAPClient library is needed by the UPS and FedEx shipping modules.
Please make sure that all mandatory server requirements are met before installing PHP Pro Bid v7.
=====================================================================

I upgraded mysql to 5.5 using webtatic and same result

I am not sure but i might need to update the libmysqlclient to higher version
currently the available packages on my server are:

# yum list mysql*

Installed Packages
mysql55w.x86_64                                                                                                         5.5.47-1.w6                                                                                                 @webtatic
mysql55w-libs.x86_64                                                                                                    5.5.47-1.w6                                                                                                 @webtatic
mysql55w-server.x86_64                                                                                                  5.5.47-1.w6                                                                                                 @webtatic
Available Packages
MySQL-python.x86_64                                                                                                     1.2.3-0.3.c1.1.el6                                                                                          base     
mysql.x86_64                                                                                                            5.1.73-5.el6_7.1                                                                                            updates 
mysql-bench.x86_64                                                                                                      5.1.73-5.el6_7.1                                                                                            updates 
mysql-connector-java.noarch                                                                                             1:5.1.17-6.el6                                                                                              base     
mysql-connector-odbc.x86_64                                                                                             5.1.5r1144-7.el6                                                                                            base     
mysql-devel.i686                                                                                                        5.1.73-5.el6_7.1                                                                                            updates 
mysql-devel.x86_64                                                                                                      5.1.73-5.el6_7.1                                                                                            updates 
mysql-embedded.i686                                                                                                     5.1.73-5.el6_7.1                                                                                            updates 
mysql-embedded.x86_64                                                                                                   5.1.73-5.el6_7.1                                                                                            updates 
mysql-embedded-devel.i686                                                                                               5.1.73-5.el6_7.1                                                                                            updates 
mysql-embedded-devel.x86_64                                                                                             5.1.73-5.el6_7.1                                                                                            updates 
mysql-libs.i686                                                                                                         5.1.73-5.el6_7.1                                                                                            updates 
mysql-libs.x86_64                                                                                                       5.1.73-5.el6_7.1                                                                                            updates 
mysql-server.x86_64                                                                                                     5.1.73-5.el6_7.1                                                                                            updates 
mysql-test.x86_64                                                                                                       5.1.73-5.el6_7.1                                                                                            updates 
mysql55w-bench.x86_64                                                                                                   5.5.47-1.w6                                                                                                 webtatic
mysql55w-devel.x86_64                                                                                                   5.5.47-1.w6                                                                                                 webtatic
mysql55w-embedded.x86_64                                                                                                5.5.47-1.w6                                                                                                 webtatic
mysql55w-embedded-devel.x86_64                                                                                          5.5.47-1.w6                                                                                                 webtatic
mysql55w-test.x86_64                                                                                                    5.5.47-1.w6                                                                                                 webtatic
[root@mcledsoft-srv3 ~]# rpm -q mysql-libs
package mysql-libs is not installed

all the packages with version 5.1xxx are available but not installed since i updated them using the webtatic package

# yum list installed | grep -i mysql

libmysqlclient16.x86_64 5.1.69-1.w6     @webtatic                               
mysql55w.x86_64         5.5.47-1.w6     @webtatic                               
mysql55w-libs.x86_64    5.5.47-1.w6     @webtatic                               
mysql55w-server.x86_64  5.5.47-1.w6     @webtatic                               
perl-DBD-MySQL.x86_64   4.013-3.el6     @base                                   
php56w-mysqlnd.x86_64   5.6.19-1.w6     @webtatic 

any ideas how can i perform this update libmysqlclient

thx
M.Moukalled

Offline
*****
Re: How to upgrade libmysqlclient to higher than 5.1
« Reply #1 on: April 12, 2016, 08:29:35 AM »
Hi, better to use MariaDB Server instead MySQL.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: How to upgrade libmysqlclient to higher than 5.1
« Reply #2 on: April 23, 2016, 04:55:54 PM »
I had such a big headache with this but finally solved it to make it work!

Basically, no matter whether you choose MySQL or MariaDB, the base installed is MySQL 5.1 which sorely needs to be updated so that others don't have to go through one whole week of downtime because of this just to install CWP!!

After doing a clean install and before installing CWP, upgrade MySQL 5.1 immediately to 5.5+. Then only do you continue with installing CWP, and for my case with MariaDB. After that, phpMyAdmin worked beautifully with UTF8MB4!!


Offline
*****
Re: How to upgrade libmysqlclient to higher than 5.1
« Reply #3 on: April 24, 2016, 03:41:50 AM »
You can base install mariadb 10.1(latest build) instead of mysql 5.1
http://centos-webpanel.com/cwp-installation
« Last Edit: April 24, 2016, 01:13:36 PM by Sandeep »

Offline
*****
Re: How to upgrade libmysqlclient to higher than 5.1
« Reply #4 on: April 25, 2016, 10:24:08 AM »
Hello.

Or you can upgrade your existing MySQL server and libs to MariaDB.

You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services