Author Topic: Starting httpd: (98)Address already in use  (Read 23299 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Starting httpd: (98)Address already in use
« on: April 12, 2016, 09:48:57 PM »
How can i fix this issue guys ? When i rebooted the server, running but after a few hour again down.

Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #1 on: April 13, 2016, 05:44:18 AM »
have you check apache error_log since there should be something or maybe by checking /var/log/messages ?

AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #2 on: April 17, 2016, 07:43:29 AM »
How can i fix this issue guys ? When i rebooted the server, running but after a few hour again down.

Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

same problem with new patch.

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #3 on: April 17, 2016, 08:17:47 AM »
I need new patch to fixed.

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #4 on: April 18, 2016, 02:49:08 PM »
This issue being present since last update   CWP version: 0.9.8.12

Telling someone check /var/log/message when you guys know fully aware this bug that introduced in last update.

I have CWP version: 0.9.8.12 on 3 vps  and 2 dedicated servers and they all have same issue.






Offline
*****
Re: Starting httpd: (98)Address already in use
« Reply #5 on: April 18, 2016, 03:13:20 PM »
do you have ssl enabled for your sites ?

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #6 on: April 18, 2016, 03:46:44 PM »
do you have ssl enabled for your sites ?

use apache and nginx only.

Offline
*****
Re: Starting httpd: (98)Address already in use
« Reply #7 on: April 18, 2016, 03:55:33 PM »
do you have ssl enabled for your sites ?

use apache and nginx only.
Do nginx using port 80 or 8181?
« Last Edit: April 18, 2016, 03:58:20 PM by Sandeep »

Offline
*****
Re: Starting httpd: (98)Address already in use
« Reply #8 on: April 18, 2016, 04:02:20 PM »
if you're using nginx as reverse proxy, uninstall nginx and use Apache only and see if the problem is resolved or not

don't forget to rebuild the vhost

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #9 on: April 18, 2016, 04:38:11 PM »
if you're using nginx as reverse proxy, uninstall nginx and use Apache only and see if the problem is resolved or not

don't forget to rebuild the vhost

do you have ssl enabled for your sites ?

use apache and nginx only.
Do nginx using port 80 or 8181?

yes, uninstall nginx have issue same.

Offline
*****
Re: Starting httpd: (98)Address already in use
« Reply #10 on: April 18, 2016, 09:10:55 PM »
contact cwp support team for further investigations.

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #11 on: April 19, 2016, 06:44:37 AM »
contact cwp support team for further investigations.
I wait feedback cwp support.

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #12 on: April 19, 2016, 11:52:59 AM »
This does appear to be a major bug. There are other processes running on port 80 or 8181. You need to kill the running processes which can be done with the command fuser -k 80/tcp if httpd has stopped or fuser -k 8181/tcp if nginx has stopped.

Offline
*****
Re: Starting httpd: (98)Address already in use
« Reply #13 on: April 19, 2016, 01:20:58 PM »
Im running 5 vps and 2 dedicated servers in which i never experienced this bugs.

Offline
*
Re: Starting httpd: (98)Address already in use
« Reply #14 on: April 19, 2016, 01:43:59 PM »
When can we expect someone to chime in and actually fix a widespread issue?

You cannot use this panel if hosting clients as soon they add new domain Apache reload fails.

It rather amazing the developers not even updated us with least an eta for fix.

You can use following commands to restore httpd service
 
1. killall -9 httpd
2. /etc/init.d/httpd restart

but this is not fix
« Last Edit: April 19, 2016, 02:47:20 PM by lmbeta8 »