Author Topic: Upgrade to PHP 5.5.9  (Read 9554 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Upgrade to PHP 5.5.9
« on: April 16, 2016, 07:52:13 AM »
How can i safely upgrade my php version to at least 5.5.9?
Is there any automatic package installer or something like that?

thanks a lot!

Offline
*****
Re: Upgrade to PHP 5.5.9
« Reply #1 on: April 16, 2016, 08:33:41 AM »
you can install php 5.5.30 from php switcher

Offline
*
Re: Upgrade to PHP 5.5.9
« Reply #2 on: April 16, 2016, 08:36:11 AM »
you can install php 5.5.30 from php switcher

thanks for your reply.
I need at least version 5.5.9 for my app to run properly

Offline
*****
Re: Upgrade to PHP 5.5.9
« Reply #3 on: April 16, 2016, 08:45:04 AM »
5.5.30 have all the functionality of 5.5.9

Offline
*
Re: Upgrade to PHP 5.5.9
« Reply #4 on: April 17, 2016, 08:42:00 AM »
5.5.30 have all the functionality of 5.5.9

that actually does not help me.
I need to install pagekit (  https://pagekit.com ) which depends on 5.5.9 and won't install with any version below.
I also do not want to "hack" the installation to run under 5.5.3 because it will cause further problems with plugins.

Any recommendations how to upgrade the php version safely with centos web panel are appreciated.

Offline
*****
Re: Upgrade to PHP 5.5.9
« Reply #5 on: April 17, 2016, 11:25:05 AM »
System requirements

Make sure your server meets the following requirements.

    Apache 2.2+ or nginx
    MySQL Server 5.1+ or SQLite 3
    PHP Version 5.5.9+

Did you know the meaning of "+" ?
it means pagekit will run flawlessly with php 5.5.9 + i.e. 5.5.10, 5.5.xx and even with 5.6.x

requirements :
http://bit.ly/1Tcw1jq
« Last Edit: April 17, 2016, 11:27:21 AM by Sandeep »

Offline
*****
Re: Upgrade to PHP 5.5.9
« Reply #6 on: April 17, 2016, 11:45:37 AM »
I installed with php 5.6 and its working fine :


More screenshots : http://imgur.com/a/7nhPB
« Last Edit: April 17, 2016, 11:50:21 AM by Sandeep »